Closed Bug 1311680 Opened 5 years ago Closed 5 years ago

System add-ons should not get reported as "making Firefox run slowly"

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1309946
Tracking Status
firefox52 --- affected

People

(Reporter: jaws, Unassigned)

References

(Blocks 1 open bug)

Details

Today I came back to my computer after it had been left alone overnight and I had a notification bar at the bottom that said, "Multi-process staged rollout might be making Nightly run slowly".

This is bad for two reasons: 1, the add-on shouldn't be making Firefox run slowly because it is actually quite a simple add-on, and 2, users don't opt-in to installing this add-on so they likely don't know of its existence so they may feel that their Firefox install got "hacked".

For issue 1, we may need to investigate why this add-on was incorrectly (or correctly) marked as making Firefox run slowly. I'm unaware if there is already any work ongoing to make this metric better.

For issue 2, we should mark system add-ons as exempt from this type of warning. This bug should focus on issue 2.
Rob: This could be one way that system add-ons are getting disabled for users, though I doubt we'd be hitting it as much as we saw.
Blocks: 1307569
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309946
You need to log in before you can comment on or make changes to this bug.