Use gecko-t-* workers for gecko tests

RESOLVED FIXED in Firefox 51

Status

defect
RESOLVED FIXED
3 years ago
6 months ago

People

(Reporter: dustin, Assigned: hammad13060)

Tracking

unspecified
mozilla53
Dependency tree / graph

Firefox Tracking Flags

(firefox51 fixed, firefox52 fixed, firefox53 fixed)

Details

Attachments

(2 attachments)

These are currently desktop-test-*, and should be replaced with properly-named workerTypes.
Blocks: 1220686
Haard -- do you want to try this out, too?  It's similar to bug 1307771 where you did such a great job!
Flags: needinfo?(panchalhaard)
Flags: needinfo?(panchalhaard)
Assignee

Comment 2

3 years ago
Hey Dustin I would like to get assigned to this bug. Where can I start ?
Flags: needinfo?(dustin)
Have a look at bug 1307771 for the general approach here.  The idea will be to replace workerTypes for all test jobs in this case.  I can take care of setting up the new workerTypes when the time comes.
Assignee: dustin → hammad13060
Flags: needinfo?(dustin)
Assignee

Comment 4

3 years ago
Attachment #8812403 - Flags: review?(dustin)
Comment on attachment 8812403 [details] [diff] [review]
changing desktop-test-* to gecko-t*

Review of attachment 8812403 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good!

Having a look at https://tools.taskcluster.net/aws-provisioner/ which lists our workerTypes, I see gecko-t-win*.  Let's use gecko-t-linux* here, instead.  I'll change that while landing your patch instead of asking for a new patch.
Attachment #8812403 - Flags: review?(dustin) → review+
Hm, something's odd with that patch -- it's missing the end of some lines, and should have more lines at the bottom.  Was that the output of 'hg diff'?
Assignee

Comment 7

3 years ago
(In reply to Dustin J. Mitchell [:dustin] from comment #6)
> Hm, something's odd with that patch -- it's missing the end of some lines,
> and should have more lines at the bottom.  Was that the output of 'hg diff'?

hg diff shows some more lines at the end I just pasted relevant parts in the patch.
That's (sort of) OK for review, but doesn't work when I try to land the patch.  Using mozreview is best, but if not, it's important to capture all of the diff output.  If this try job works, I'll land the patch.
Assignee

Comment 10

3 years ago
(In reply to Dustin J. Mitchell [:dustin] from comment #9)
> That's (sort of) OK for review, but doesn't work when I try to land the
> patch.  Using mozreview is best, but if not, it's important to capture all
> of the diff output.  If this try job works, I'll land the patch.
I can push the patch on mozreview if you want ?
Comment hidden (mozreview-request)
Reporter

Comment 12

3 years ago
mozreview-review
Comment on attachment 8813160 [details]
Bug 1311810 - Use gecko-t-* workers for gecko tests

https://reviewboard.mozilla.org/r/94686/#review94892

Thanks for the mozreview!

However, the tests on this try push will not run, because the workerTypes have a different name (gecko-t-linux-{xlarge,large,medium}).  I used that different name in https://treeherder.mozilla.org/#/jobs?repo=try&revision=85c10485cbc2 which succeeded.  So I'll land that patch.

Drop by in #tc-contributors sometime today and we'll see what you want to work on next!
Attachment #8813160 - Flags: review+
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Component: Integration → Build Config
Product: Taskcluster → Firefox
Resolution: FIXED → ---
Comment on attachment 8813160 [details]
Bug 1311810 - Use gecko-t-* workers for gecko tests

Approval Request Comment
[Feature/Bug causing the regression]:

aurora and beta are using the old workerTypes, and since runs on those workerTypes are few and far between, it takes a while to start the instances up -- meaning longer wait times for these repos.

[User impact if declined]: slower tests

[Is this code covered by automated tests?]: yes

[Has the fix been verified in Nightly?]: yes

[Needs manual test from QE? If yes, steps to reproduce]:  no

[List of other uplifts needed for the feature/fix]: none

[Is the change risky?]: no

[Why is the change risky/not risky?]: been running in central for a long time

[String changes made/needed]: none
Attachment #8813160 - Flags: approval-mozilla-beta?
Attachment #8813160 - Flags: approval-mozilla-aurora?
This is not part of the build, I don't think it needs relman approval.
Whiteboard: checkin-needed-aurora] [checkin-needed-beta]
Attachment #8813160 - Flags: approval-mozilla-beta?
Attachment #8813160 - Flags: approval-mozilla-aurora?
Don't reopen bugs if they're fixed on trunk. Status flags are used to track uplifts.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53

Comment 18

3 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/735074bc84c3
Whiteboard: checkin-needed-aurora] [checkin-needed-beta] → [checkin-needed-beta]
needs rbasing for beta
Flags: needinfo?(hammad13060)
Assignee

Comment 20

3 years ago
to which changeset should I rebase ?
Flags: needinfo?(hammad13060) → needinfo?(cbook)
Flags: needinfo?(cbook)
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 53 → mozilla53
You need to log in before you can comment on or make changes to this bug.