Location Bar autocomplete takes me to the completely wrong page, if I hit "down" and then "enter" to select an autocomplete result for a page that's already loading/loaded in another tab

RESOLVED DUPLICATE of bug 1303781

Status

()

Firefox
Address Bar
P2
normal
RESOLVED DUPLICATE of bug 1303781
a year ago
5 months ago

People

(Reporter: dholbert, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxsearch])

Attachments

(4 attachments)

(Reporter)

Description

a year ago
Created attachment 8803129 [details]
screencast of bug

(Unfortunately this is a bug that I can't reproduce in a fresh profile. Filing it anyway, as it's *extremely* annoying. I think it might just require a sufficiently-huge history database, or something.)

STR:
 1. Have https://bugzilla.mozilla.org/enter_bug.cgi?product=Core bookmarked and in your history.
 2. Have https://search.yahoo.com/yhs/search?p=enter&ei=UTF-8&hspart=mozilla&hsimp=yhs-002 in your awesomebar history (from accidentally doing a Yahoo search for "enter" in the past).
 3. Open a new tab, type "enter" and then hit downarrow to select the Bugzilla entry, and then hit enter.
 4. Repeat step 3.

EXPECTED RESULTS:
I should end up with two tabs at 
 https://bugzilla.mozilla.org/enter_bug.cgi?product=Core 

ACTUAL RESULTS:
My first tab ends up at Bugzilla, but my second tab ends up at my Yahoo search-results page!!! (despite the fact that it was NOT what was focused when I hit enter)

I suspect the issue here is that we pull the Bugzilla-bookmark out of the awesomebar suggestions, as soon as that tab loads, and we replace it with a "switch to tab" entry.  (but there's some race condition, so that doesn't actually happen visually)  And so when I hit Enter on the Bugzilla-bookmark, the awesomebar ends up dropping me to the next entry, which happens to be this Yahoo search results page.

Screencast coming up, showing this bug in all its annoying glory. :-/  I run into this several times per week -- often several times per day. (Not usually with the exact "open two tabs back to back" STR that I outlined here -- that just happens to be an easy way to trigger this.)
(Reporter)

Updated

a year ago
Summary: Location Bar autocomplete takes me to the completely wrong page, if I hit "down" and then "enter" to select an autocomplete result → Location Bar autocomplete takes me to the completely wrong page, if I hit "down" and then "enter" to select an autocomplete result for a page that's already loading/loaded in another tab
(Reporter)

Comment 1

a year ago
Created attachment 8803133 [details]
screenshot 1: how it looks when I press "Enter"

I'm attaching 3 screenshots from my screenshot, that show the bug pretty unequivocally.

Here's the first screenshot -- this is what it looks like when I press "Enter".  Notice that I have the Bugzilla page focused. (though the Yahoo entry is directly below it, after a switch-to-tab option).
(Reporter)

Updated

a year ago
Attachment #8803133 - Attachment description: screenshot → screenshot 1: how it looks when I press "Enter"
(Reporter)

Comment 2

a year ago
Created attachment 8803134 [details]
screenshot 2: how it looks just after I press "enter" (still good)

Here's a screenshot an instant after I press "enter". Notice that:
 - the autocomplete dropdown has disappeared.
 - the URLbar still has the URL that I want to visit (bugzilla)
(Reporter)

Comment 3

a year ago
Created attachment 8803136 [details]
screenshot 3: another instant later (BAD)

And here's another screenshot, an instant after screenshot 2 -- notice that now the location bar's contents have now *changed* to the yahoo search-results page!!

As demonstrated by my screenshots: this bogus change is happening *after* I hit enter (screenshot 1), and after we close the autocomplete area (screenshot 2).  It seems to be some delayed annoying effect of some race condition that's happening under the hood.
(Reporter)

Comment 4

a year ago
(Those screenshots are all taken from around the 0:05-second mark in my screencast, BTW)

Mak, is this something you've encountered before or seen any bugs on?

It feels to me like this regressed in the last ~6 months, though I'm not entirely sure.  I have e10s disabled in this profile, too, if it matters.
(Reporter)

Updated

a year ago
Flags: needinfo?(mak77)
I actually think this may be the same as bug 1303781. It shouldn't matter that you have a yahoo search in history. Thanks to your screenshot I see at the bottom of the popup your first one-off button is yahoo!
We currently buffer Enter but we don't do anything for DOWN or TAB yet, that means when you DOWN+ENTER or TAB+ENTER quickly, we didn't hear back from history yet, so the only existing results are the heuristic one (search) and the one off button. you basically select the first one off button and confirm it.

Your screencast seems to show that you select the right thing but I sort of suspect it's only a "ghost" of the previous query (we have this bug filed too).
If you notice in the second tab the one-off button for yahoo gets "magically" selected just before pressing enter.
Flags: needinfo?(mak77)
Priority: -- → P2
Whiteboard: [fxsearch]
Depends on: 1303781
(Reporter)

Comment 6

9 months ago
Pretty sure this is a dupe of bug 1303781, indeed.

(I'm still hitting this multiple times per week (perhaps multiple times per day), and it's super annoying. :(  Really hoping we can get it fixed before long.)
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1303781
Depends on: 1369016
You need to log in before you can comment on or make changes to this bug.