Status

defect
RESOLVED DUPLICATE of bug 1310801
3 years ago
Last year

People

(Reporter: Oriol, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

1. Open web console
2. Enter the string "\x00"
3. No result is shown. The console stops working. Browser console shows

> chrome://devtools/content/webconsole/webconsole.xul : Unable to run script because scripts are blocked internally. (unknown)
> XML Parsing Error: not well-formed Location: Line Number 1, Column 1130:  (unknown)
> SyntaxError: An invalid or illegal string was specified  react.js:19876

https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=37f78aca862224d7151c0fcae1ed8373fe11c83b&tochange=a5510966f80b9b2f5abf59ab32cf4c92d66c60de
This is a bug in a lower level library called Reps. It has a patch that is checkin-needed
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1310801
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.