SVG <use href=""> is broken when cloned from <template> after pushState is used

RESOLVED DUPLICATE of bug 652991

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 652991
10 months ago
4 months ago

People

(Reporter: herrernst, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Created attachment 8803279 [details]
firefox-svg-href-template.html

I have a template element, which references SVG symbols ("spritesheet"). After using pushState to change current URL, SVG symbol in cloned template are not shown anymore (please see attachment).
(Reporter)

Comment 1

10 months ago
Works in current Chrome, Safari, MS Edge.

Updated

10 months ago
Component: General → SVG
Product: Firefox → Core

Updated

10 months ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 months ago
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 652991
You need to log in before you can comment on or make changes to this bug.