Keyword search is always performed in lowercase

RESOLVED FIXED in Firefox 52

Status

()

Firefox
Location Bar
P2
normal
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: Alice0775 White, Assigned: mak)

Tracking

({regression, ux-consistency})

51 Branch
Firefox 52
regression, ux-consistency
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxsearch])

(Reporter)

Description

8 months ago
[Tracking Requested - why for this release]: UX regression wor keyword search resuls. The search parameter should be case sensitive.

The problem occurs with newly created profile.

Reproducible: always

Steps To Reproduce:
1. Open about:preferences#search
2. Assign keyword "g" to Google search engine.
3. Type "g LALALA" in location bar and hit [Enter]

Actual Results:
Google search results shows "lalala" in search fields in the page

Expected Results:
The search parameter should be case sensitive.
Google search results shows "LALALA" in search fields in the page.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=64cd7d87e78cf2e4b919aad10fb9f4962834b004&tochange=70d19ed29c980ba3d6825e5286bda08fa7dc676f

Regressed by: 70d19ed29c98	Marco Bonardo — Bug 1306639 - Searching in locationbar by typing something and pressing enter is not accounted in telemetry. r=adw
Flags: needinfo?(mak77)
(Assignee)

Comment 1

8 months ago
it may be the same problem as bug 1310737.
Regardless I can add a test for this there.
Depends on: 1310737
Flags: needinfo?(mak77)
Tracking 52+ - UX issue - we should respect lower and upper case.
tracking-firefox52: ? → +

Updated

8 months ago
Priority: -- → P2
Whiteboard: [fxsearch]

Comment 3

8 months ago
Track 51+ as regression in keyword search.
tracking-firefox51: ? → +

Comment 4

8 months ago
Hi Alice,
Could you help verify if this issue is fixed as expected on the latest Nightly build given bug 1210737 was fixed? Thanks!
Flags: needinfo?(alice0775)
(Reporter)

Updated

8 months ago
Status: NEW → RESOLVED
Last Resolved: 8 months ago
status-firefox50: unaffected → ---
status-firefox51: affected → ---
status-firefox52: affected → ---
tracking-firefox51: + → ---
tracking-firefox52: + → ---
No longer depends on: 1310737
Flags: needinfo?(alice0775)
Resolution: --- → DUPLICATE
Duplicate of bug: 1310737
(Reporter)

Comment 6

8 months ago
Yep, the bug 1310737 fixed this problem.
(Assignee)

Comment 7

8 months ago
let's actually mark this as fixed so it's easier to track as an additional STR for QA.
Resolution: DUPLICATE → FIXED
(Assignee)

Updated

8 months ago
Target Milestone: --- → Firefox 52
(Assignee)

Updated

8 months ago
Assignee: nobody → mak77
You need to log in before you can comment on or make changes to this bug.