Closed Bug 1312100 Opened 3 years ago Closed 3 years ago

Enable a11y+e10s by default for OSX/Linux in Fx52

Categories

(Core :: Disability Access APIs, defect)

48 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: jimm, Assigned: jimm)

References

Details

Attachments

(1 file, 1 obsolete file)

Firefox on OSX does not enable e10s if a11y activity has been detected. Currently we do not have open crash or other types of blockers preventing us from turning this on.. so lets do it!

The plan:

1) enable in Nightly (target: Fx 53) 
2) let the feature roll out to beta and monitor for stability issues
3) If all looks good on beta, roll out to release.
Assignee: nobody → jmathies
davidb tells me the a11y team would like to target 52 for this, so updating.
Summary: Enable a11y+e10s by default for OSX in Fx53 → Enable a11y+e10s by default for OSX in Fx52
Duplicate of this bug: 1312102
Summary: Enable a11y+e10s by default for OSX in Fx52 → Enable a11y+e10s by default for OSX/Linux in Fx52
Attached patch patch (obsolete) — Splinter Review
Attachment #8804245 - Flags: review?(felipc)
Comment on attachment 8804245 [details] [diff] [review]
patch

Review of attachment 8804245 [details] [diff] [review]:
-----------------------------------------------------------------

IIRC a11y on OSX barely "worked" before e10s, and it was made worse with e10s.. Did anyone check that basic VoiceOver support will not be regressed by enabling e10s?
Attachment #8804245 - Flags: review?(felipc) → review+
(In reply to :Felipe Gomes (needinfo me!) from comment #5)
> Comment on attachment 8804245 [details] [diff] [review]
> patch
> 
> Review of attachment 8804245 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> IIRC a11y on OSX barely "worked" before e10s, and it was made worse with
> e10s.. Did anyone check that basic VoiceOver support will not be regressed
> by enabling e10s?

Tracy, please test VoiceOver with e10s on and off in nightly to see where we are at.
Flags: needinfo?(twalker)
I wouldn't call VoiceOver a usable accessibility tool with Firefox.  Simple things like reading through search results don't work.  Certain sub-menu items (like those in our awesome bar) are also not read by VoiceOver.  This sort of broken behavior is present on Release as well as Nightly in non-e10s and e10s.  

That said, to determine if/what has regressed from non-e10s to e10s, a full QA test plan of VoiceOver and its function across our browser should be created and implemented.  Is that something you want me to do here, Jim?
Flags: needinfo?(twalker) → needinfo?(jmathies)
(In reply to Tracy Walker [:tracy] from comment #7)
> I wouldn't call VoiceOver a usable accessibility tool with Firefox.  Simple
> things like reading through search results don't work.  Certain sub-menu
> items (like those in our awesome bar) are also not read by VoiceOver.  This
> sort of broken behavior is present on Release as well as Nightly in non-e10s
> and e10s.  
> 
> That said, to determine if/what has regressed from non-e10s to e10s, a full
> QA test plan of VoiceOver and its function across our browser should be
> created and implemented.  Is that something you want me to do here, Jim?

That sounds like a very good idea. I'd love to know what slipped through the e10s crash when we rolled out. From Davidb, we officially don't support a11y on OSX, but we generally want to avoid regressing working features. So lets figure out where things are at.
Flags: needinfo?(jmathies) → needinfo?(twalker)
Keywords: checkin-needed
(In reply to Jim Mathies [:jimm] from comment #8)
> (In reply to Tracy Walker [:tracy] from comment #7)
> > I wouldn't call VoiceOver a usable accessibility tool with Firefox.  Simple
> > things like reading through search results don't work.  Certain sub-menu
> > items (like those in our awesome bar) are also not read by VoiceOver.  This
> > sort of broken behavior is present on Release as well as Nightly in non-e10s
> > and e10s.  
> > 
> > That said, to determine if/what has regressed from non-e10s to e10s, a full
> > QA test plan of VoiceOver and its function across our browser should be
> > created and implemented.  Is that something you want me to do here, Jim?
> 
> That sounds like a very good idea. I'd love to know what slipped through the
> e10s crash when we rolled out. From Davidb, we officially don't support a11y
> on OSX, but we generally want to avoid regressing working features. So lets
> figure out where things are at.

s/crash/cracks :)
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e71702af187b
Enable a11y with e10s for Linux/OSX on all channels. r=felipe
Keywords: checkin-needed
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cdd2fcf94281
Backed out changeset e71702af187b for bustage
Attached patch patch v.2Splinter Review
Attachment #8804245 - Attachment is obsolete: true
Flags: needinfo?(jmathies)
Attachment #8806699 - Flags: review+
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6dca348b9b1d
Enable a11y with e10s for Linux/OSX on all channels. r=felipe
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6dca348b9b1d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Jim and I discussed the VoiceOver case in 1:1. We determined full blown testing of this isn't worthwhile since the feature is 1) not supported and 2) VoiceOver wasn't really usable in non-e10s. (ie.  VoiceOver would not read page content). If plans are made to support and get full compatibility of Firefox with VoiceOver, then a full testing effort can be set into motion.
Flags: needinfo?(twalker)
Yeah, we'd really like to support OSX but can't prioritize that anytime soon. Until things improve there, we can expect roughly 0.05% of FF mac users to instantiate a11y.
You need to log in before you can comment on or make changes to this bug.