Closed Bug 1312724 Opened 8 years ago Closed 8 years ago

Broken Visual Bookmarks add-on

Categories

(WebExtensions :: General, defect)

defect
Not set
normal

Tracking

(firefox50- unaffected, firefox51- fixed, firefox52- fixed)

RESOLVED FIXED
Tracking Status
firefox50 - unaffected
firefox51 - fixed
firefox52 - fixed

People

(Reporter: vtamas, Assigned: mash)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached file addon-2.30.2-fx.xpi
[Affected versions]:
Firefox 52.0a1 (2016-10-24)

[Affected platforms]:
Windows 10 64-bit
Mac OS X 10.11.6

[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Install the attached add-on:
3.Open a new tab.


[Expected Results]:
Visual Bookmarks favorite sites are successfully displayed while opening a new tab.( http://screencast.com/t/7iyp74eu )


[Actual Results]:
The classical new tab page is opened.( http://screencast.com/t/MSc8F0jTRZq )


[Regression Range]:
Last good revision: 9eab2642989dee91264d169ba613a86a488b02ab
First bad revision: a9a143d2179a352652b970b99d062214d1bf9bd8
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=9eab2642989dee91264d169ba613a86a488b02ab&tochange=a9a143d2179a352652b970b99d062214d1bf9bd8


Looks like the following bug has the changes which introduced the regression: Bug 1309350
Flags: needinfo?(kmaglione+bmo)
This is a bug in the extension:

lib/utils/logger/index.js:18:const appConfig = require('../../../../config');

has an extra ../

I'm not sure how it ever worked in the first place, though...
Flags: needinfo?(kmaglione+bmo)
Also line 9:

const appDirs = require('../../modules/common/dirs');

I changed both those lines and it worked just fine. I'll contact the add-on author to let them know.
So. The reason this previously worked, in case anyone else is interested:

"lib/utils/logger/index.js" + "../../../../config" is pre-resolved to
"../config".

The old loader first tries to load this as "resource://config.js" and fails.

Then it tries, in order:

- lib/utils/logger/node_modules/../config.js
- lib/utils/node_modules/../config.js
- lib/node_modules/../config.js

The last one is the same as 'lib/config.js', so it works.

The new loader code refuses to resolve "resource://vb-at-yandex-dot-ru/" +
"../config.js" to "resource://config.js" (as it should), so it throws before
it gets to the (invalid) node_modules resolution step.
[Tracking Requested - why for this release]: Addon breakage
Thank you! We will upload new version after replace deprecated jQuery version inside.
Tracking 52- as this appears to be resolved by the add on author making a code adjustment.
Danil, can you please let us know when this is fixed?

Thanks
Assignee: nobody → mash
Component: General → Add-ons
Flags: needinfo?(mash)
Product: Add-on SDK → Tech Evangelism
Un-track for 51 as this will be fixed by add-on author.
Tracking 50- - as noted in Comment 9, this is gated on the addon author.
Version 2.30.3 which fixes this is currently in the AMO review queue.
Performed a bit of exploratory testing around this new version - 2.30.3 - and it seems to work as expected across all versions (Firefox 52.0a1 (2016-11-02), Firefox 51.0a2 (2016-11-02), Firefox 50.0 RC, Firefox 49.0.2) under Windows 10 64-bit and Ubuntu 12.04 64-bit.
Untracked and based on the latest testing by SV, 50 may be unaffected.
2.30.5 (like 2.30.3) is available in the AMO.
Thank you.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(mash)
Resolution: --- → FIXED
Component: Add-ons → General
Product: Tech Evangelism → WebExtensions
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: