Closed Bug 1312833 Opened 5 years ago Closed 5 years ago

Removed MediaStreamTrack stopped when it shouldn't be (regression)

Categories

(Core :: WebRTC: Audio/Video, defect)

52 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1312332
Tracking Status
firefox52 --- affected

People

(Reporter: jib, Unassigned)

References

()

Details

STR:
 1. Open URL and share camera + mic.
 2. Wait 2 seconds.

Expected result: Video appears and the following output:

  live
  Stopping 1 originals
  live
  gUM is on

Actual result: No video appears and the following output:

  live
  Stopping 1 originals
  ended
  gUM is off

Even though the fiddle removes the video track and uses it in a new stream with a video element, and never stops this track, the track is nonetheless stopped when the audio track is stopped.

This appears to be a regression from bug 1294605.
Isn't this bug 1312332?
Flags: needinfo?(jib)
Yes, that was it, thanks!
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jib)
Resolution: --- → DUPLICATE
Duplicate of bug: 1312332
No longer blocks: 1294605
You need to log in before you can comment on or make changes to this bug.