Plugins don't work in mach-o browser build

RESOLVED DUPLICATE of bug 155256

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 155256
16 years ago
15 years ago

People

(Reporter: Patrick C. Beard, Assigned: Patrick C. Beard)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

16 years ago
The problem is that plugins are built as CFM shared libraries, which aren't
supported by NSPR, and even if they were, the mach-o browser can't call CFM
function pointers directly. In addition there are many places in the plugin code
where we have to distinguish between XP_UNIX and XP_MAC. Patches coming.
(Assignee)

Comment 1

16 years ago
Created attachment 74422 [details] [diff] [review]
plugin module patch v1

These are the changes to the plugin module to support loading CFM plugins on
mach-o.
(Assignee)

Comment 2

16 years ago
Created attachment 74427 [details] [diff] [review]
Patch to nsObjectFrame.cpp v1

Patches to layout module to support plugins on XP_MACOSX.
(Assignee)

Updated

16 years ago
Depends on: 131306

*** This bug has been marked as a duplicate of 155256 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.