ImmutableBinding of "ES-6" not work in loop "for-in"

RESOLVED DUPLICATE of bug 449811

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 449811
a year ago
a year ago

People

(Reporter: Ivan, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

Im run code:

let o = { a:1, s:2, d:3, f:4, g:5, h:6};

for(let i in o){
  setTimeout(function(){
    alert(i)
  }, 0);
}




Actual results:

That code always alerting 'h' symbol.


Expected results:

Should be alerting sequence of all keys ('a', 's', 'd', 'f', 'g', 'h')
dupe of bug 449811 and it's fixed in bug 1263355 (firefox 51).
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 449811
You need to log in before you can comment on or make changes to this bug.