Closed Bug 1313344 Opened 8 years ago Closed 7 years ago

WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate (CustomizableUIInternal.buildArea)

Categories

(Firefox :: Private Browsing, defect)

35 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: whimboo, Unassigned)

References

Details

WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
CustomizableUIInternal.buildArea@resource://app/modules/CustomizableUI.jsm:684:27
CustomizableUIInternal.registerToolbarNode@resource://app/modules/CustomizableUI.jsm:672:9
this.CustomizableUI.registerToolbarNode@resource://app/modules/CustomizableUI.jsm:3063:5
_init@chrome://browser/content/customizableui/toolbar.xml:85:11
onReadyStateChange@chrome://browser/content/customizableui/toolbar.xml:37:15
EventListener.handleEvent*toolbar_XBL_Constructor@chrome://browser/content/customizableui/toolbar.xml:33:13

https://dxr.mozilla.org/mozilla-central/rev/3f4c3a3cabaf94958834d3a8935adfb4a887942d/browser/components/customizableui/CustomizableUI.jsm#684
Couldn't reproduce this WARNING while using the Customize panel - neither from a regular window nor a private window.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.