[Presentation API] [debug build only] Fennec crashes after running a test from http://w3c-test.org

REOPENED
Unassigned

Status

()

Core
DOM
P3
minor
REOPENED
a year ago
a year ago

People

(Reporter: u421692, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox52 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8805177 [details]
crash_presentation_api

Environment: 
Device: Nexus 6 (Android 6.0.1)
Build: https://people.mozilla.org/~schien/fennec-52.0a1.en-US.android-arm.apk
Chromecast + TV

Steps to reproduce(intermittent):
1. Load http://w3c-test.org/presentation-api/controlling-ua/reconnectToPresentation_success-manual.html
2. Start the presentation with the blue button
3. From the Android Notification Bar tap on the DISCONNECT button

Expected result:
The connection is closed

Actual result:
Fennec crashes

PS: please see the attached logs, the build I've tested on doesn't have the crash reporter enabled
(Reporter)

Updated

a year ago
Summary: Fennec crashes after running a test from http://w3c-test.org → [Presentation API] Fennec crashes after running a test from http://w3c-test.org
(Reporter)

Updated

a year ago
Blocks: 1184036
No longer blocks: 1313368
from the adb logcat, an assertion happened in GLContext.h after closing a presentation.

10-27 19:11:50.698: D/GeckoBrowser(17376): -*- CastingApp -*-: <kuoe0> mediaPlayerDevice:observe MediaPlayer:Changed
10-27 19:11:50.709: I/qdhwcomposer(280): prepare: Unsupported layer count for mdp composition
10-27 19:11:50.715: I/Gecko(17376): [Main Thread]: D/Presentation virtual nsresult mozilla::dom::PresentationTCPSessionTransport::OnStopRequest(nsIRequest*, nsISupports*, nsresult):aStatusCode[0]
10-27 19:11:50.715: I/Gecko(17376): [Main Thread]: D/Presentation virtual nsresult mozilla::dom::PresentationSessionInfo::NotifyTransportClosed(nsresult):id[{13f05f77-2fbb-478e-9181-67c2596f7940}], reason[0], role[2]
10-27 19:11:50.715: I/Gecko(17376): [Main Thread]: D/Presentation virtual void mozilla::dom::PresentationSessionInfo::Shutdown(nsresult):id[{13f05f77-2fbb-478e-9181-67c2596f7940}], reason[0], role[2]
10-27 19:11:50.716: I/Gecko(17376): virtual void mozilla::dom::PresentationPresentingInfo::Shutdown(nsresult)
10-27 19:11:50.716: I/Gecko(17376): [Main Thread]: D/Presentation virtual nsresult mozilla::dom::PresentationTCPSessionTransport::OnStopRequest(nsIRequest*, nsISupports*, nsresult):aStatusCode[0]
10-27 19:11:50.716: I/Gecko(17376): [Main Thread]: D/Presentation virtual nsresult mozilla::dom::PresentationSessionInfo::NotifyTransportClosed(nsresult):id[{13f05f77-2fbb-478e-9181-67c2596f7940}], reason[0], role[1]
10-27 19:11:50.716: I/Gecko(17376): [Main Thread]: D/Presentation connection state change:id[{13f05f77-2fbb-478e-9181-67c2596f7940}], state[2], reason[0], role[1]
10-27 19:11:50.716: I/Gecko(17376): [Main Thread]: D/Presentation virtual void mozilla::dom::PresentationSessionInfo::Shutdown(nsresult):id[{13f05f77-2fbb-478e-9181-67c2596f7940}], reason[0], role[1]
10-27 19:11:50.726: I/qdhwcomposer(280): prepare: Unsupported layer count for mdp composition
10-27 19:11:50.733: A/MOZ_Assert(17376): Assertion failure: IsCurrent(), at /Users/hellfire/workspace/github/gecko-dev/gfx/gl/GLContext.h:722
Duplicate of this bug: 1304978
(Reporter)

Comment 3

a year ago
I wasn't able to reproduce this issue anymore on this build https://people-mozilla.org/~schien/presentation-api/fennec-52.0a1.en-US.android-arm.apk. 
I will reopen if I will be able to reproduce again
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Keep this bug open since it can still reproduced on debug build, but lower the priority because it cannot be reproduced on release build.
Severity: critical → minor
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: [Presentation API] Fennec crashes after running a test from http://w3c-test.org → [Presentation API] [debug build only] Fennec crashes after running a test from http://w3c-test.org
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.