Convert NS_STYLE_USER_MODIFY, NS_STYLE_WINDOW_DRAGGING and NS_STYLE_ORIENT to enum classes

RESOLVED FIXED in Firefox 52

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: adamtomasv, Assigned: adamtomasv, Mentored)

Tracking

(Blocks 1 bug)

unspecified
mozilla52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(3 attachments)

Assignee

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161024172922
Assignee

Updated

3 years ago
Blocks: 1277133
Mentor: manishearth
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee: nobody → adamtomasv

Comment 4

3 years ago
mozreview-review
Comment on attachment 8805433 [details]
Bug 1313565 - Convert NS_STYLE_USER_MODIFY_* to enum class ;

https://reviewboard.mozilla.org/r/89168/#review88590
Attachment #8805433 - Flags: review?(manishearth) → review+
Attachment #8805433 - Flags: review?(xidorn+moz)
Attachment #8805434 - Flags: review?(xidorn+moz)
Attachment #8805435 - Flags: review?(xidorn+moz)

Comment 5

3 years ago
mozreview-review
Comment on attachment 8805434 [details]
Bug 1313565 - Convert NS_STYLE_WINDOW_DRAGGING_* to enum class ;

https://reviewboard.mozilla.org/r/89170/#review88594

::: layout/style/nsStyleStruct.h:3316
(Diff revision 1)
>             nsChangeHint_ReflowChangesSizeOrPosition |
>             nsChangeHint_ClearAncestorIntrinsics;
>    }
>  
> -  mozilla::StyleUserSelect mUserSelect;   // [reset] (selection-style)
> -  uint8_t   mForceBrokenImageIcon; // [reset]  (0 if not forcing, otherwise forcing)
> +  mozilla::StyleUserSelect     mUserSelect;     // [reset](selection-style)
> +  uint8_t                      mForceBrokenImageIcon; // [reset]

Since the comment for `mForceBrokenImageIcon` isn't aligned anyway, we can just keep `mForceBrokenImageIcon` unaligned (one space after the `uint8_t`).

Comment 6

3 years ago
mozreview-review
Comment on attachment 8805434 [details]
Bug 1313565 - Convert NS_STYLE_WINDOW_DRAGGING_* to enum class ;

https://reviewboard.mozilla.org/r/89170/#review88596
Attachment #8805434 - Flags: review?(manishearth) → review+

Comment 7

3 years ago
mozreview-review
Comment on attachment 8805435 [details]
Bug 1313565 - Convert NS_STYLE_ORIENT_* to enum class ;

https://reviewboard.mozilla.org/r/89172/#review88598
Attachment #8805435 - Flags: review?(manishearth) → review+
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Attachment #8805434 - Flags: review?(xidorn+moz)
Attachment #8805435 - Flags: review?(xidorn+moz)

Comment 10

3 years ago
mozreview-review
Comment on attachment 8805433 [details]
Bug 1313565 - Convert NS_STYLE_USER_MODIFY_* to enum class ;

https://reviewboard.mozilla.org/r/89168/#review88680
Attachment #8805433 - Flags: review?(xidorn+moz) → review+

Comment 11

3 years ago
mozreview-review
Comment on attachment 8805434 [details]
Bug 1313565 - Convert NS_STYLE_WINDOW_DRAGGING_* to enum class ;

https://reviewboard.mozilla.org/r/89170/#review88682
Attachment #8805434 - Flags: review?(xidorn+moz) → review+

Comment 12

3 years ago
mozreview-review
Comment on attachment 8805435 [details]
Bug 1313565 - Convert NS_STYLE_ORIENT_* to enum class ;

https://reviewboard.mozilla.org/r/89172/#review88684
Attachment #8805435 - Flags: review?(xidorn+moz) → review+
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 16

3 years ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6b80fdaeadfc
Convert NS_STYLE_USER_MODIFY_* to enum class ; r=manishearth,xidorn
https://hg.mozilla.org/integration/autoland/rev/cb8c35d77841
Convert NS_STYLE_WINDOW_DRAGGING_* to enum class ; r=manishearth,xidorn
https://hg.mozilla.org/integration/autoland/rev/050803173323
Convert NS_STYLE_ORIENT_* to enum class ; r=manishearth,xidorn

Comment 17

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6b80fdaeadfc
https://hg.mozilla.org/mozilla-central/rev/cb8c35d77841
https://hg.mozilla.org/mozilla-central/rev/050803173323
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.