Closed Bug 1313664 Opened 8 years ago Closed 8 years ago

White flashes displayed on Pinterest while scrolling using END and HOME keys

Categories

(Core :: Web Painting, defect)

defect
Not set
normal
14

Tracking

()

RESOLVED INVALID
Tracking Status
platform-rel --- +
firefox50 --- affected
firefox51 --- affected
firefox52 --- affected

People

(Reporter: cbadau, Unassigned)

Details

(Whiteboard: [platform-rel-Pinterest])

[Affected versions]:
- latest Nightly 52.0a1 (2016-10-28)
- latest Aurora 51.0a2 (2016-10-28)
- Firefox 50 Beta 11
- Firefox 41.0.2 (2015-10-13)

[Affected platforms]:
- Windows 7 x64
- Mac OS X 10.11

[Steps to reproduce]:
1. Launch Firefox and go to https://www.pinterest.com/ . 
2. Scroll multiple times the page using END and HOME keys.  

[Expected result]:
- The scrolling is smooth, without any jerkiness or rendering issues.

[Actual result]:
- White flashes displayed while scrolling the page using END and HOME keys. Please see issue here: http://imgur.com/a/HPzPB  

[Regression range]:
- The issue is also reproducible on Firefox 41.0.2 (buildID: 20151013193107)

[Additional notes]:
- The issue is not related to APZ: the issue is reproducible with "layers.async-pan-zoom.enabled" set to false.
Component: Keyboard Navigation → Layout: View Rendering
Product: Firefox → Core
platform-rel: --- → ?
Whiteboard: [platform-rel-Pinterest]
This is just checkerboarding, right, kats?
platform-rel: ? → +
Component: Layout: View Rendering → Panning and Zooming
Flags: needinfo?(bugmail)
(In reply to Andrew Overholt [:overholt] from comment #1)
> This is just checkerboarding, right, kats?

This suggests otherwise:

> [Additional notes]:
> - The issue is not related to APZ: the issue is reproducible with
> "layers.async-pan-zoom.enabled" set to false.
What Botond said. Also the fact that it's reproducible on Firefox 41.0.2 which didn't have APZ enabled at all. It might very well be "fake checkerboarding" in that Pinterest doesn't populate the DOM with content until you scroll down, but it could be something else.
Component: Panning and Zooming → Layout: View Rendering
Flags: needinfo?(bugmail)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #3)
> It might very well be "fake
> checkerboarding" in that Pinterest doesn't populate the DOM with content
> until you scroll down, but it could be something else.

Oh, that's interesting. And the video from comment 0 does indeed look like that! Camelia, could this perhaps be network lag?

(Sorry for my incorrect knee jerk diagnosis, APZ folks :)
Flags: needinfo?(camelia.badau)
Rank: 14
I've retested on latest Nightly 53.0a1 (2016-12-04) and the issue is still reproducible.

Also, I've reproduced the issue on a different network. Therefore, I don't think that's a network lag.
Flags: needinfo?(camelia.badau)
Any other ideas here - to move this forward?
Flags: needinfo?(overholt)
Flags: needinfo?(bugs)
I recovered my Pinterest password and tried this again. It happens the same in Chrome so I don't think this is a Gecko or Firefox bug.

FWIW, they do seem to be serving different content to different UAs: in Firefox I get some sort of infinitely-growing list of photos when I first log in vs. in Chrome I only get that if I search for something. But I think that's irrelevant to this bug.

The resolution being INVALID here isn't at all reflective of the value of bug reports like this. Thanks, Camelia.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(overholt)
Flags: needinfo?(camelia.badau)
Flags: needinfo?(bugs)
Resolution: --- → INVALID
Should we report this to them via our Dl since it's potentially cross browser? And do we perhaps have a potential solution for them to attempt.
Flags: needinfo?(miket)
We could let them know, but I don't think we fully understand the bug, or have a solution (and since it's happening in multiple browsers, it suggests a bug on their end).
Flags: needinfo?(miket)
The discussion with Pinterest suggests that there will be changes and that they will sit with some Firefox engineers and perform some in-depth profiling of scrolling performance.
Flags: needinfo?(camelia.badau)
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.