touchscreen on Windows: there's a trail that follows your finger around the screen

RESOLVED INVALID

Status

()

Core
Widget: Win32
RESOLVED INVALID
2 years ago
11 months ago

People

(Reporter: Will, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
using a Surface Pro 4 tablet, when scrolling or just dragging your finger across the screen in Firefox, there's a trail that follows your finger around. It's distracting and weird. Can anyone give a reason or explain why there should be a trail behind your finger? I don't think any other browser does this
(Reporter)

Comment 1

2 years ago
someone just contacted me about this and it turns out this is a Windows behaviour that has nothing to do with Firefox. so this is not a bug and can be deleted. my apologies

Updated

2 years ago
Component: General → Widget: Win32
Product: Firefox → Core

Comment 2

2 years ago
Resolving per comment #1. :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

a year ago
I think this should be reopened because I forgot to test this in Internet Explorer when I filed this, I just tried it now and in Internet Explorer, this annoying trail is not present. I think that is significant because, although the trail isn't present in Edge either, Internet Explorer is of course a win32 app, so that must mean this annoying trail is not 'mandatory', surely there is a way to get rid of it?

Comment 4

a year ago
(In reply to Will from comment #3)
> I think this should be reopened because I forgot to test this in Internet
> Explorer when I filed this, I just tried it now and in Internet Explorer,
> this annoying trail is not present. I think that is significant because,
> although the trail isn't present in Edge either, Internet Explorer is of
> course a win32 app, so that must mean this annoying trail is not
> 'mandatory', surely there is a way to get rid of it?

I see the same trail trying to move an IE window with touch, on a current version of Windows 10. I don't see it in the content area. :kats, sorry for picking on you in several bugs, but is there something we can/should do to disable this mousetrail in certain circumstances?
Flags: needinfo?(bugmail)
I never noticed that the trail doesn't appear in IE/Edge. I'm not really sure how they turn it off - maybe they have access to an internal API? I looked on MSDN and didn't see any exposed API that allows this, but maybe I missed it. However, there is a user-facing option in the control panel to turn this off. Control Panel -> Pen and Touch -> Touch -> "Show visual feedback when touching the screen".
Flags: needinfo?(bugmail)
(Reporter)

Comment 6

11 months ago
Can someone please remove the "invalid" label because this is still quite annoying and distracting

Comment 7

11 months ago
(In reply to Will from comment #6)
> this is still quite annoying and distracting

Did you disable the OS-level option like Kats suggested?

(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #5)
> there is a user-facing option in the control panel to
> turn this off. Control Panel -> Pen and Touch -> Touch -> "Show visual
> feedback when touching the screen".
You need to log in before you can comment on or make changes to this bug.