If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Awesome Screenshot Plus doesn’t work for addons.mozilla.org pages

RESOLVED DUPLICATE of bug 1310082

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1310082
11 months ago
11 months ago

People

(Reporter: vasilica_mihasca, Unassigned)

Tracking

({regression})

unspecified
regression
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, firefox50 wontfix, firefox51 wontfix, firefox52 wontfix)

Details

[Affected versions]:
Firefox 52.0a1 (2016-10-30)
Firefox 51.0a2 (2016-10-30)
Firefox 50.0b11 (20161027110534)


[Affected platforms]:
Windows 10 64-bit
Mac OS X 10.11.6
Ubuntu 16.04 32-bit


[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Install https://addons.mozilla.org/en-US/firefox/addon/awesome-screenshot-capture-/
3.While the above amo page is still opened, click on the webextension icon and select the following options: “Delayed capture”, “Capture selected area”, “Capture entire page”.


[Expected Results]:
All the Awesome Screenshot Plus options work as expected including on amo pages.


[Actual Results]:
   - “Delayed capture”, “Capture selected area”, “Capture entire page” options do not work on amo pages.
   - The following errors are thrown in Browser Console:
Error: Could not establish connection. Receiving end does not exist.  (unknown)
Unchecked lastError value: Error: No window matching {"matchesHost":["        <all_urls>","https://accounts.google.com/o/oauth2/token"]}  ExtensionUtils.jsm:397
Use of getPreventDefault() is deprecated.  Use defaultPrevented instead.  Jquery-1.7.2.min.js:3:7108
Unknown localization message upload_title  popup.js:251


[Regression Range]:
Last good revision: 7759e701fea14a2b17cdb4dc0fb7d797856afd40
First bad revision: 63e401d16993f2b17a69c92eabd385d2f2e256fb
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7759e701fea14a2b17cdb4dc0fb7d797856afd40&tochange=63e401d16993f2b17a69c92eabd385d2f2e256fb


Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1295324
(Reporter)

Updated

11 months ago
Flags: needinfo?(aswan)
This is on purpose, see bug 1310082.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(aswan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1310082
To give more details, capturing screenshots of web pages is not the thing that's blocked at the moment, but this extension breaks because it also depends on injecting content scripts in mozilla.org websites, which is forbidden.
Marking wontfix based on bug 1310082.
status-firefox50: affected → wontfix
status-firefox51: affected → wontfix
status-firefox52: affected → wontfix
You need to log in before you can comment on or make changes to this bug.