Closed Bug 1314016 Opened 3 years ago Closed 3 years ago

Crash in mozilla::dom::TabParent::RecvPDocAccessibleConstructor

Categories

(Core :: Disability Access APIs, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox50 --- unaffected
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: marcia, Assigned: aklotz)

References

Details

(Keywords: crash, regression, topcrash, Whiteboard: aes+)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-7a9f78d4-9e77-42f2-ad14-42cf32161031.
=============================================================

New crash that has risen to the top of trunk crashes - started with 20161029062601: http://bit.ly/2dUPwSr.

Maybe a manifestation of another bug, not sure. ni on Aaron since the top stack touches code worked on in Bug 1309236.
Flags: needinfo?(aklotz)
This is RecvMsaaID reincarnate.
Flags: needinfo?(aklotz)
Whiteboard: aes+
Attached patch PatchSplinter Review
Since AddChildDoc can fail (in which case there is no wrapper), we need to check that before calling WrapperFor and SetID.
Assignee: nobody → aklotz
Status: NEW → ASSIGNED
Attachment #8806514 - Flags: review?(tbsaunde+mozbugs)
Comment on attachment 8806514 [details] [diff] [review]
Patch

if it fails the tab will crash, but that's better than the main process crashing.  I suspect the real problem here is the same as all the other PDocAccessibleConstructor stuff, and I may have something that finally really works for that.
Attachment #8806514 - Flags: review?(tbsaunde+mozbugs) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/eb1336d8898f8b84de79b5a9e152ce82ed4fb3df
Bug 1314016: Do not attempt to obtain wrapper and set MSAA ID on child document unless it was successfully added; r=tbsaunde
https://hg.mozilla.org/mozilla-central/rev/eb1336d8898f
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
hi, this signature is also crashing on 51.0b & the patch looks fairly simple. would the fix be upliftable in terms of scope/risk?
Flags: needinfo?(aklotz)
Comment on attachment 8806514 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 1309236
[User impact if declined]: Crashes, though only users who have force-enabled e10s should be seeing them.
[Describe test coverage new/current, TreeHerder]: On 52+, crash is gone.
[Risks and why]: None, just a null pointer check
[String/UUID change made/needed]: None
Flags: needinfo?(aklotz)
Attachment #8806514 - Flags: approval-mozilla-beta?
Comment on attachment 8806514 [details] [diff] [review]
Patch

Fix a crash. Beta51+. Should be in 51 beta 2.
Attachment #8806514 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Blocks: 1341731
You need to log in before you can comment on or make changes to this bug.