If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

window.close() closes all window instead of Tab

VERIFIED DUPLICATE of bug 103452

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 103452
16 years ago
9 years ago

People

(Reporter: Malx, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
If you browsing web with Tabs and you see page with pop-ups, there is button:
<a href=javascript:self.close()>Close window</a> - and this refers to pop-up window.

If that window whould be swallowed into Tab, then click on this link will close 
all window with all tabs there!!!

I thinks this is bug (especially if you remember, that self.close() 1. should not
affect other(not own) windows , 2. could be called automatically without mouse
click).

Proposed solution - self.close() should close only the Tab it is in.

Comment 1

16 years ago
dup of bug 103452 ?
(Reporter)

Comment 2

16 years ago
Sorry... it is

*** This bug has been marked as a duplicate of 103452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.