Add GPU process type to existing metrics

RESOLVED FIXED in Firefox 53

Status

Cloud Services
Metrics: Pipeline
P3
normal
RESOLVED FIXED
7 months ago
3 months ago

People

(Reporter: dvander, Assigned: mdoglio)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

unspecified
mozilla53
Points:
3
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
We now have a new process type, "gpu", in addition to the existing process types (browser, content, plugin, gmp). Any place where this list is hardcoded, we have to make sure the GPU process is factored in as well. In particular we want to make sure that crash data is aggregated properly.
Depends on: 1314227
Depends on: 1314231
Depends on: 1314626

Comment 1

7 months ago
how soon is this needed David? P3 means Q1 2017 right now
Points: --- → 3
Flags: needinfo?(dvander)
Priority: -- → P3
(Reporter)

Comment 2

7 months ago
(In reply to thuelbert from comment #1)
> how soon is this needed David? P3 means Q1 2017 right now

We are hoping that this feature will ship with Firefox 53 - which would be midway through Q2 2017. Q1 2017 seems like a reasonable target.
Flags: needinfo?(dvander)
(Reporter)

Updated

5 months ago
Blocks: 1264543
No longer blocks: 1307578
(In reply to thuelbert from comment #1)
> how soon is this needed David? P3 means Q1 2017 right now

This feature is being tested in nightly and it is difficult to understand it without data in the pipeline. Can we raise the priority of this issue?
Flags: needinfo?(thuelbert)
I'd like to call attention to this as a release blocker for GPU Process and ask that this get reprioritized. 

I let it go for the A/B Telemetry Experiment currently active on Nightly until Jan 11. Right now I'm doing manual data analysis of this experiment with Crash Stats which does not give us a complete picture. The preliminary data looks promising but it would be good to have Telemetry data to validate our assumptions. We really need Telemetry *and* Socorro data to make smart decisions about quality. 

Flagging Milan for further context as necessary.
Flags: needinfo?(milan)
(Assignee)

Comment 5

5 months ago
I can tackle the changes required to crash_aggregates next week. That will make gpu crashes available via re:dash. In the meantime you can use spark to analyze the raw telemetry data via ATMO.
(Assignee)

Updated

5 months ago
Assignee: nobody → mdoglio
Status: NEW → ASSIGNED
(In reply to Mauro Doglio [:mdoglio] from comment #5)
> I can tackle the changes required to crash_aggregates next week. That will
> make gpu crashes available via re:dash. In the meantime you can use spark to
> analyze the raw telemetry data via ATMO.

Awesome, thanks!
(In reply to Mauro Doglio [:mdoglio] from comment #5)
> I can tackle the changes required to crash_aggregates next week. That will
> make gpu crashes available via re:dash. In the meantime you can use spark to
> analyze the raw telemetry data via ATMO.

Thanks Mauro, does this mean I should be able to query the data for the duration of our experiment (went live Dec 24)?
(Assignee)

Comment 8

5 months ago
If with data you mean crash aggregates yes, correct.

Comment 9

5 months ago
Created attachment 8825109 [details] [review]
[telemetry-batch-view] mozilla:bug-1314173-gpu-crashes > mozilla:master
(Assignee)

Comment 10

5 months ago
I added gpu_crashes to crash_aggregates.stats and backfilled the data starting from Dec 24th as requested.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
(Assignee)

Updated

5 months ago
Duplicate of this bug: 1314626

Comment 12

4 months ago
clearing needs info - see Mauros comments above.

Updated

4 months ago
Flags: needinfo?(thuelbert)
Flags: needinfo?(milan)
Target Milestone: --- → mozilla53
status-firefox53: --- → fixed
You need to log in before you can comment on or make changes to this bug.