webextensions not loaded on https://addons.mozilla.org/

RESOLVED DUPLICATE of bug 1310082

Status

RESOLVED DUPLICATE of bug 1310082
2 years ago
5 months ago

People

(Reporter: juraj.masiar, Unassigned)

Tracking

50 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161027110534

Steps to reproduce:

I already filed issue here:
https://github.com/mdn/webextensions-examples/issues/136
Reproduction:
1) using Firefox beta 50.0b11, use Temporary load addon like https://github.com/mdn/webextensions-examples/tree/master/emoji-substitution
2) visit any page on domain https://addons.mozilla.org/
3) addon is not gonna be loaded to that page, you cannot see it in debugger either


Actual results:

Content script is not loaded even when it's using "matches": ["<all_urls>"]


Expected results:

Addon should be loaded on all urls including addons.mozilla.org.
This works in release version 49.
(Reporter)

Comment 1

2 years ago
Somebody on github wrote that this is by design. But I found it hard to believe {or I don't want to believe}. If I install web-extension on addons.mozilla.org then I will test it on the current page and that's the only domain where it wont ever work? This will lead to worse user experience.

Updated

2 years ago
Component: Untriaged → WebExtensions: Untriaged
Product: Firefox → Toolkit
Summary: extensions not loaded on https://addons.mozilla.org/ → webextensions not loaded on https://addons.mozilla.org/
Yes, this is (hopefully) temporary, and on purpose: see bug 1310082.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1310082

Updated

5 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.