Crash in ShadowLayerChild::ActorDestroy on GPU process restart

RESOLVED FIXED in Firefox 52

Status

()

Core
Graphics: Layers
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

(Blocks: 1 bug)

unspecified
mozilla52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(1 attachment)

This was discovered by a try run with a forced crash in the GPU process. Example:

https://treeherder.mozilla.org/#/jobs?repo=try&author=danderson@mozilla.com&selectedJob=30216098

ShadowLayerChild::mLayer is probably null.
Created attachment 8808017 [details] [diff] [review]
bug1314349.patch

Turns out that the SendPLayerConstructor call was failing, so the ShadowableLayer was never attached in the opposite direction. This patch only assigns a ShadowableLayer to ShadowaLayerChild if the constructor succeeds.
Assignee: nobody → dvander
Status: NEW → ASSIGNED
Attachment #8808017 - Flags: review?(matt.woodrow)
Attachment #8808017 - Flags: review?(matt.woodrow) → review+

Comment 2

2 years ago
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9438fd24fd96
Don't attach shadowable layers if IPDL fails to construct an actor. (bug 1314349, r=mattwoodrow)

Comment 3

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9438fd24fd96
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Duplicate of this bug: 1316267
You need to log in before you can comment on or make changes to this bug.