doesn't show rules on elements which have styles applied from userContent.css

RESOLVED DUPLICATE of bug 1291321

Status

defect
RESOLVED DUPLICATE of bug 1291321
3 years ago
Last year

People

(Reporter: jinuodd, Unassigned)

Tracking

49 Branch

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

3 years ago
no rules are shown (not just userContent.css rules) on elements which have styles applied from userContent.css

e.g., go to https://www.google.com/ and use inspector to select the logo (id="hplogo") -- you should see several style rules in the right pane.

now add to userContent.css (and then restart Firefox):
#hplogo{border:1px solid red;}

use inspector to select the logo again ... this time no rules are shown.
Reporter

Comment 1

3 years ago
for what it's worth, this problem doesn't exist in Firebug.
Bug 1046166 (userContent.css broken with e10s) might be at least tangentially related to this.

Is e10s enabled for you?  You can check in about:support, look for the "Multiprocess Windows" section.
Flags: needinfo?(jinuodd)
See Also: → 1046166
Reporter

Comment 3

3 years ago
i do not have e10s enabled.
Flags: needinfo?(jinuodd)

Comment 4

3 years ago
Fixed in 50+ (with e10s off):
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=938ce16be25f9c551c19ef8938e8717ed3d41ff5&tochange=5d854c8d076533b9426bc3040979ccf8e0b2404b
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1291321

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.