Closed Bug 1314450 Opened 4 years ago Closed 3 years ago

this._updateAutoScrollEnabled is not a function error when tearing off

Categories

(Instantbird :: Conversation, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Instantbird 52

People

(Reporter: florian, Assigned: aleth)

Details

(Whiteboard: [1.6-blocking])

Attachments

(1 file)

TypeError: this._updateAutoScrollEnabled is not a function
	autoScrollEnabled chrome://chat/content/convbrowser.xml:347:47
	bound autoScrollEnabled self-hosted
	handleLastMessage chrome://instantbird/content/instantbird.xul:124:9

If the conversation was the last tab of the window, the window fails to close.

The problem is the 2 bound functions at http://searchfox.org/comm-central/source/chat/content/convbrowser.xml#916

                this.contentWindow.scrollToElement = this._scrollToElement.bind(this);
                this.contentWindow.autoScrollEnabled = this.autoScrollEnabled.bind(this);

These should be updated when swapping the docshells.
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Comment on attachment 8806931 [details] [diff] [review]
Update methods exposed to content when swapping docshells

Review of attachment 8806931 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! The code change looks good, I assume you verified it has the intended effect.
Attachment #8806931 - Flags: review?(florian) → review+
https://hg.mozilla.org/comm-central/rev/dd56104d2a03835869611acc5837e5f74cfeb5fd
Bug 1314450 - Update methods exposed to content when swapping docshells. r=florian
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Instantbird 52
You need to log in before you can comment on or make changes to this bug.