Closed Bug 1314573 Opened 3 years ago Closed 3 years ago

Logged Object-like and Array-like grip should show the first 10 items

Categories

(DevTools :: Console, defect)

defect
Not set

Tracking

(firefox53 fixed)

RESOLVED FIXED
Firefox 53
Tracking Status
firefox53 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

Details

Attachments

(3 files)

We are currently having a limit of 100 items, this should be lowered to 10
Assignee: nobody → chevobbe.nicolas
Blocks: 1314571
Status: NEW → ASSIGNED
No longer blocks: 1314571
Component: Developer Tools: Shared Components → Developer Tools: Console
Summary: Reps "long" mode should preview the first 10 items for Object-like and Array-like grip → Logged Object-like and Array-like grip should show the first 10 items
Duplicate of this bug: 1314571
Comment on attachment 8811905 [details]
Bug 1314573 - Uses Reps in long mode in the console;

https://reviewboard.mozilla.org/r/93802/#review93956
Attachment #8811905 - Flags: review?(bgrinstead) → review+
Comment on attachment 8811904 [details]
Bug 1314573 - Make Reps "long" mode displays first 10 items for object & array-like grips;

https://reviewboard.mozilla.org/r/93800/#review94114

R+ assuming try is green.

Thanks Nicolas!
Honza
Attachment #8811904 - Flags: review?(odvarko) → review+
Comment on attachment 8811906 [details]
Bug 1314573 - Modify textNode Reps modes to match elementNodeRep;

https://reviewboard.mozilla.org/r/93804/#review94116

LGTM!

Honza
Attachment #8811906 - Flags: review?(odvarko) → review+
Pushed by chevobbe.nicolas@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cb9bce246733
Make Reps "long" mode displays first 10 items for object & array-like grips; r=Honza
https://hg.mozilla.org/integration/autoland/rev/ab533a828db6
Uses Reps in long mode in the console; r=bgrins
https://hg.mozilla.org/integration/autoland/rev/8b0c2149edc0
Modify textNode Reps modes to match elementNodeRep; r=Honza
https://hg.mozilla.org/mozilla-central/rev/cb9bce246733
https://hg.mozilla.org/mozilla-central/rev/ab533a828db6
https://hg.mozilla.org/mozilla-central/rev/8b0c2149edc0
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.