The default bug view has changed. See this FAQ.

[One-off searches] Changing the default search engine from Search bar does not work first time

VERIFIED FIXED

Status

()

Firefox
Search
P2
normal
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: Liviu Cirdei [Away-Please need info Brindusa Tot], Assigned: standard8)

Tracking

({regression})

51 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 verified, firefox52 verified)

Details

(Whiteboard: [fxsearch][fixed by bug 1297374])

[Affected versions]:
Aurora 51

[Affected platforms]:
All

[Steps to reproduce]:
1. Open Aurora 51 and type something in Search bar.
2. Right-click on a one-off searches icons. (e.g. Wikipedia).
3. From context menu click "Set as default search engine". 

[Expected Result]: 
The search engine should be set as default.

[Actual Result]: 
The search engine is not set as default. Repeating this with other engines does not set any of them as default engine until the Search bar is closed and reopened. 
This happens only for the first time the user starts Firefox or any time he opens a new window and opens the Search bar.

[Regression]:
Pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=109281cadd425161c50bce8ab4064faa68c4113c&tochange=3b3e87b91108ced2173ae34357cfed8db7cfe6c0

Probably regressed by Bug 1297976 - Fix accessibility for the unified one-off search buttons in the urlbar and searchbar

[Notes]
[1] This reproduces on Aurora where the oneOffSearches from Awesomebar is disabled.
[2] This was reproducible also on Nightly if the "browser.urlbar.oneOffSearches" was set to false UNTIL bug 1297374 was fixed. So bug 1297374 fixed this issue, but only on Nightly. I think the easiest way to fix this is to uplift the fix from bug 1297374 to Aurora.
Comment hidden (obsolete)
Comment hidden (obsolete)

Comment 3

5 months ago
Hi ::mak,
Per notes [2] in description, do you think we need to uplift the fix of bug 1297374 to 51 aurora to fix this issue?
Flags: needinfo?(mak77)
(In reply to Marco Bonardo [::mak] from comment #2)
> (In reply to Milan Sreckovic [:milan] from comment #1)
> > One off search is enabled in Aurora?
> 
> No, it shouldn't be, and Aurora bugs won't be fixed.

It looks to me like this bug is about one offs in the search bar, not the awesomebar; if so it's been enabled since Firefox 34.

Comment 5

5 months ago
Ah sorry, I misread the bug as being related to the awesomebar (so confusing). This is about one-off buttons in the search bar.

Yes, it could be worth uplifting bug 1297374 if it fixes this bug in the searchbar.
Flags: needinfo?(mak77)

Updated

5 months ago
Priority: -- → P2
Whiteboard: [fxsearch]
(In reply to Florian Quèze [:florian] [:flo] from comment #4)

> It looks to me like this bug is about one offs in the search bar, not the
> awesomebar; if so it's been enabled since Firefox 34.

Even if it is in the search bar, this bug was introduced by the Awesomebar work. (See the regression range from the report). It is not the first time when the one-off searches from awesomebar work affects search bar, and until now Drew fixed the bugs even for Aurora (uplifting the fix). As I know oneoff searches is disabled in Aurora but some code is still touched and my cause regressions, like this one.

Comment 7

5 months ago
makes sense, most of the code is now shared.
(Assignee)

Comment 8

5 months ago
I'll take a look in a bit and see how easy it is to uplift that patch.
Assignee: nobody → standard8
(Assignee)

Comment 9

5 months ago
This is the same bug as bug 1297374. It doesn't matter which way the preference is set, bug 1180944 added the buttons to the urlbar and in doing so changed some code which accidentally caused the regression.

Since this will be an uplift of the same bug fix I'm going to mark this as duplicate of bug 1297374 and deal with the uplift there - it'll be clearer for drivers.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1297374
(Assignee)

Comment 10

5 months ago
Oh, and now I remember this isn't exactly the same bug, but I still think its worth managing in the same place.
(Assignee)

Comment 11

5 months ago
Ok, to make this all clearer, changing the annotation to fixed by bug 1297374.

Setting verified for 52 as per comment 0.
status-firefox52: unaffected → verified
Depends on: 1297374
Resolution: DUPLICATE → FIXED
Whiteboard: [fxsearch] → [fxsearch][fixed by bug 1297374]
Mark 51 fixed as this was fixed in 51 of bug 1297374.
status-firefox51: affected → fixed
The fix is verified on Aurora 51.0a2 (Build ID 	20161105004017). I tested on:
*Windows 10
*Ubuntu 16.04
*Mac 10.11

Changing the default search engine from search bar works as expected.
Status: RESOLVED → VERIFIED
status-firefox51: fixed → verified
You need to log in before you can comment on or make changes to this bug.