Remove all the regexp goop from Web IDL parser and codegen

RESOLVED FIXED in Firefox 53

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: bzbarsky, Assigned: bzbarsky)

Tracking

(Blocks: 1 bug)

Trunk
mozilla53
Points:
---

Firefox Tracking Flags

(firefox53 fixed)

Details

Attachments

(1 attachment)

It's gone from the Web IDL spec.
Created attachment 8807393 [details] [diff] [review]
Remove the RegExp (and some Date) special casing from our dictionary conversions and Web IDL overload resolution
Attachment #8807393 - Flags: review?(peterv)
Duplicate of this bug: 1315221
Attachment #8807393 - Flags: review?(peterv) → review+

Comment 3

2 years ago
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/83f951d60fc7
Remove the RegExp (and some Date) special casing from our dictionary conversions and Web IDL overload resolution.  r=peterv

Comment 4

2 years ago
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9f6533d92b96
followup.  Fix web platform tests that either depended on the old spec's behavior or were asserting that we fail the new one.

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/83f951d60fc7
https://hg.mozilla.org/mozilla-central/rev/9f6533d92b96
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
status-firefox52: affected → ---
You need to log in before you can comment on or make changes to this bug.