Closed Bug 1315254 Opened 6 years ago Closed 6 years ago

Scrolling the page using the swipe gesture with a pen does not work when Pointer Events is preffed on

Categories

(Core :: DOM: Events, defect, P3)

52 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox52 --- affected

People

(Reporter: asimonca, Assigned: stone)

References

Details

[Affected versions]:
- Nightly 52.0a1

[Affected platforms]:
- Windows 10 x64

[Steps to reproduce]:
Make sure that the build has e10s enabled and the pref "browser.tabs.remote.force-enable" and set it to "true".

1. Go to about:config and set the "dom.w3c_pointer_events.enabled" preff to "true"
2. Go to any long page that requires scrolling (e.g. www.wikipedia.org)
3. Swipe up or down to scroll the page using a stylus.

[Expected result]:
- The page scrolls according to the gesture.

[Actual result]:
- The page does not scroll. The user can use the pen only to highlight text when the Pointer Events preff is set to "true"

[Regression range]:
- This is not a regression since this is a new feature.

[Additional notes]:
- A user can use his finger to scroll the page up and down on a touchscreen device, but not the pen when Pointer Events is preffed on.
Priority: -- → P3
Assignee: nobody → sshih
PointerEvent spec doesn't define the gestures generated from pen. Tested on Chrome 57.0.2971.0 and Edge 38.14393.0.0, swipe with pen behaves as selecting text.
Closed this bug since current behavior is as expected.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.