Closed Bug 1315262 Opened 3 years ago Closed 3 years ago

Intermittent test_suspend.html,test_fetch_basic_http.html,test_fileBlobSubWorker.xul,test_child-src_worker_data.html,test_file.xul,test_chromeWorkerJSM.xul,test_child-src_worker.html | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)]

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox-esr45 --- unaffected
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 + fixed
firefox53 - fixed

People

(Reporter: intermittent-bug-filer, Assigned: jandem)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Summary: Intermittent dom/workers/test/test_suspend.html | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)] → Intermittent dom/workers/test/test_suspend.html,test_fetch_basic_http.html,test_fileBlobSubWorker.xul | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)]
Duplicate of this bug: 1315548
Summary: Intermittent dom/workers/test/test_suspend.html,test_fetch_basic_http.html,test_fileBlobSubWorker.xul | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)] → Intermittent test_suspend.html,test_fetch_basic_http.html,test_fileBlobSubWorker.xul,test_child-src_worker_data.html | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)]
Summary: Intermittent test_suspend.html,test_fetch_basic_http.html,test_fileBlobSubWorker.xul,test_child-src_worker_data.html | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)] → Intermittent test_suspend.html,test_fetch_basic_http.html,test_fileBlobSubWorker.xul,test_child-src_worker_data.html,test_file.xul | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)]
Summary: Intermittent test_suspend.html,test_fetch_basic_http.html,test_fileBlobSubWorker.xul,test_child-src_worker_data.html,test_file.xul | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)] → Intermittent test_suspend.html,test_fetch_basic_http.html,test_fileBlobSubWorker.xul,test_child-src_worker_data.html,test_file.xul,test_chromeWorkerJSM.xul | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)]
Summary: Intermittent test_suspend.html,test_fetch_basic_http.html,test_fileBlobSubWorker.xul,test_child-src_worker_data.html,test_file.xul,test_chromeWorkerJSM.xul | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)] → Intermittent test_suspend.html,test_fetch_basic_http.html,test_fileBlobSubWorker.xul,test_child-src_worker_data.html,test_file.xul,test_chromeWorkerJSM.xul,test_child-src_worker.html | application crashed [@ js::ShapeTable::searchUnchecked<0>(jsid)]
Blocks: 1317603
Probably mine.
Flags: needinfo?(jdemooij)
Attached patch PatchSplinter Review
We shouldn't purge ShapeTables in the self-hosting zone, as that zone is shared with worker threads.
Assignee: nobody → jdemooij
Status: NEW → ASSIGNED
Flags: needinfo?(jdemooij)
Attachment #8810804 - Flags: review?(jcoppeard)
[Tracking Requested - why for this release]:
Crashes.
Comment on attachment 8810804 [details] [diff] [review]
Patch

Review of attachment 8810804 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/jsfun.cpp
@@ +1595,5 @@
>      if (comp->hasBeenEntered() && !rt->allowRelazificationForTesting)
>          return;
>  
>      // Don't relazify if the compartment is being debugged or is the
>      // self-hosting compartment.

We should probably update this comment to match.
Attachment #8810804 - Flags: review?(jcoppeard) → review+
Pushed by jandemooij@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8d6553075ae1
Don't purge shape tables in the self-hosting zone. r=jonco
https://hg.mozilla.org/mozilla-central/rev/8d6553075ae1
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8810804 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: Bug 1314569.
[User impact if declined]: Crashes.
[Describe test coverage new/current, TreeHerder]: Seems to fix oranges so far.
[Risks and why]: Low risk, just adds an extra check.
[String/UUID change made/needed]: None.
Attachment #8810804 - Flags: approval-mozilla-aurora?
Tracking 53- since this is resolved fixed.
Comment on attachment 8810804 [details] [diff] [review]
Patch

fix crashes including oranges on treeherder, take in aurora52
Attachment #8810804 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.