Generate SHA1 installers for ESR52, stop generating them for Firefox 53

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rail, Assigned: rail)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

In order to support Windows XP, we need to generate SHA1 signed installers starting with ESR52.
*XP and Vista*

We should also generating SHA1-signed installer starting with Firefox 53.
See Also: → bug 1315153
Summary: Generate SHA1 installers for ESR52 → Generate SHA1 installers for ESR52, stop generating them for Firefox 53
Title: stop generating them for Firefox 53
Comment #1: We should also generating SHA1-signed installer starting with Firefox 53.

Which is correct?
Note: If we don't generate sha-1 installers, Firefox 53+ installers will silently fail to start on XP/Vista. So bug 1305453 will be moot.
See Also: → bug 1305453
Probably this should be "blessed" by the release management team.
Assignee: nobody → rail
Priority: -- → P2
esr52: https://archive.mozilla.org/pub/firefox/candidates/52.0esr-candidates/build4/win32-sha1/

No more sha1:
release: http://archive.mozilla.org/pub/firefox/candidates/52.0-candidates/build2/
beta: http://archive.mozilla.org/pub/firefox/candidates/52.0b9-candidates/build2/

Sorry for the mess with the versions I mentioned above. Last sha1 signed installers for betas were generated in 52.0b8 and for releases is 51.0.1. We will be generating sha1 signed installer until the end of life of ESR52.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.