Can't style <option> on new <select>

RESOLVED DUPLICATE of bug 910022

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED DUPLICATE of bug 910022
10 months ago
4 months ago

People

(Reporter: Albert Juhé, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox51 wontfix, firefox52 wontfix, firefox53 wontfix, firefox54 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 months ago
Created attachment 8807779 [details]
example-select.htm

The <option> elements can't be styled (see attachments).

== Steps to reproduce ==

Create a HTML document with styled <option> elements.

== Expected results ==

<option> elements should display the style.

== Actual results ==

<option> elements appear with no style applied.

Reproduced on Firefox Nightly 52.0a1 (2016-11-04) (64-bit) Linux.
(Reporter)

Comment 1

10 months ago
Created attachment 8807780 [details]
fx-49-vx-fx-52.png

Comment 2

10 months ago
[Tracking Requested - why for this release]: Not sure what, if anything, specifications say about this and whether other browsers support styling <option>. Requesting tracking to make sure this doesn't fall through the cracks.
status-firefox51: --- → unaffected
tracking-firefox52: --- → ?
Keywords: regression

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 910022

Updated

10 months ago
tracking-firefox52: ? → ---

Updated

9 months ago
Priority: -- → P3

Updated

7 months ago
status-firefox53: --- → affected
status-firefox54: --- → affected

Comment 4

7 months ago
I can reproduce on Firefox 51.0.1 with e10s on.
status-firefox51: unaffected → affected

Comment 5

7 months ago
It's too late for 51. Mark 51 as won't fix.
status-firefox51: affected → wontfix
Fixed in 54 in the duplicate
status-firefox52: affected → wontfix
status-firefox53: affected → wontfix
status-firefox54: affected → fixed
You need to log in before you can comment on or make changes to this bug.