[regression] Search keywords are broken for POST forms now

VERIFIED FIXED in Firefox 51

Status

()

defect
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: sergemp, Assigned: mak)

Tracking

({regression})

51 Branch
Firefox 52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 verified, firefox52 verified)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20161105030211

Steps to reproduce:

0. `firefox -p`, create and select empty profile
1. Open https://duckduckgo.com/html
2. Right click in the search field, click "Add a Keyword for this Search...", enter keyword "d" and save it.
3. In url bar type "d test" and press enter



Actual results:

Search keyword doesn't work. No search results.



Expected results:

Search keyword should work, search results for the word "test" should appear.
Status: UNCONFIRMED → NEW
Has Regression Range: --- → no
Has STR: --- → yes
Component: Untriaged → Search
Ever confirmed: true
It sounds like bug 1310737, but that should be fixed on nightly.
I can reproduce this bug in aurora/devedition:
* Last good build: https://archive.mozilla.org/pub/firefox/nightly/2016/10/2016-10-13-03-02-04-mozilla-central/firefox-52.0a1.en-US.linux-i686.tar.bz2
* First bad build: https://archive.mozilla.org/pub/firefox/nightly/2016/10/2016-10-14-03-02-04-mozilla-central/firefox-52.0a1.en-US.linux-i686.tar.bz2

And in nightly:
* Last good build: https://archive.mozilla.org/pub/firefox/nightly/2016/10/2016-10-16-00-40-34-mozilla-aurora/firefox-51.0a2.en-US.linux-i686.tar.bz2
* First bad build: https://archive.mozilla.org/pub/firefox/nightly/2016/10/2016-10-17-00-40-13-mozilla-aurora/firefox-51.0a2.en-US.linux-x86_64.tar.bz2

Keyword search for post forms still doesn't work for me with todays nightly (Build ID: 20161105030211). In Web Developer/Network I see a POST request, but it's not really sent, has no visible post data and no response. I tested it with e10s disabled to be sure it's not e10s bug.

And it's not just a duckduckgo website problem. Keyword search is also broken for other websites using POST forms, for example: https://www.urbandictionary.com/, https://dnsquery.org/, http://www.cogentco.com/en/network/looking-glass, http://currentlydown.com/, some forums searches, etc.
this is a bookmark keyword, not a search keyword.
I'll look into this tomorrow.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Component: Search → Bookmarks & History
Priority: -- → P1
Whiteboard: [fxsearch]
See Also: → 1310737
I see this error in the console
NS_BASE_STREAM_CLOSED: Component returned failure code: 0x80470002 (NS_BASE_STREAM_CLOSED) [nsIMIMEInputStream.available]  RemoteWebNavigation.js:22

looks like a problem with the POST data input stream.

probably due to this typo:
+                if (action.params.postData) {
+                  postData = getPostDataStream(postData);

This indicates we clearly need a full browser-chrome test of the whole "add keyword for this search and then use it" experience.
Blocks: 1314013
Comment on attachment 8808349 [details]
Bug 1315514 - Bookmark keywords are still broken for POST forms.

https://reviewboard.mozilla.org/r/91170/#review91058

Argh, nice catch.  Thanks for the test.
Attachment #8808349 - Flags: review?(adw) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/7348925c1148
Bookmark keywords are still broken for POST forms. r=adw
https://hg.mozilla.org/mozilla-central/rev/7348925c1148
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Blocks: 1310737
I have reproduced this bug with Nightly 52.0a1 (2016-11-05) (64-bit) on Windows 7, 64 Bit ! 

This bug's fix is verified with latest Nightly

Build ID    20161109030210
User Agent  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

 [bugday-20161109]
merged into aurora with bug 1310737
It works now! Thank you!
Flags: qe-verify+
I reproduced this issue using 52.0a1, build ID: 20161107030203, on Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx 51.0b10, build ID: 20161222080852 and Fx 52.0a2, build ID: 20161228004005 on Windows 10 x64, Mac OS X 10.11 and Ubuntu 14.04 LTS.

Cheers!
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.