no check for mail if messenger isn't started

VERIFIED DUPLICATE of bug 11056

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 11056
17 years ago
14 years ago

People

(Reporter: Harald Glatt, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020316
BuildID:    2002031608

If you have the turbo mode enabled so mozilla is running in systray of Windows
but you don't have any other mozilla windows open like messenger or navigator
then it doesn't check for new mail and therefore it doesn't bring the mail
notification icon up.

Reproducible: Always
Steps to Reproduce:
1. set up mozilla to check for mail every minute
2. write a mail to yourself
3. have a messenger or navigator window open...
4. wait a minute
5. you have mail and there's hopefully a new icon in your systray because of the
new mail you received...
6. now send onther mail
7. close all windows so mozilla only runs in tray...
8. there won't come an icon that you have new mail....

Comment 1

17 years ago
Changing component to Quick Launch.
Assignee: asa → law
Component: Browser-General → QuickLaunch (AKA turbo mode)
QA Contact: doronr → gbush

Comment 2

16 years ago
I may be seeing a similar problem.  The systray icon still shown unread mail
after I've read the mail.  CLicking on the icon dosen't update its status nor
check for new mail.

2002040103 win32
(Reporter)

Comment 3

16 years ago
My real problem is... it doesn't check for mail if no messenger window is open
... Meanwhile I'm starting to think that it ONLY checks for mail if a messenger
window is opened... That has to be solved...
Summary: mozilla doesn't check for new mail only running in systray → mozilla doesn't check for new mail when only running in systray
(Reporter)

Updated

16 years ago
Component: QuickLaunch (AKA turbo mode) → Browser-General
Summary: mozilla doesn't check for new mail when only running in systray → no check for mail if messenger isn't started
(Reporter)

Comment 4

16 years ago
this bugs root is somewhere else... changing summery and component...
The matter that it doesn't check for mail if running in systray only depends on
the bug that it never checks for mail except a messenger window is open...

Comment 5

16 years ago
Initially testing this on commercial trunk 2002040103
on NT 4.0, if I follow steps to reproduce, reporter is
correct.

But after waiting 2 minutes after step 8
>7. close all windows so mozilla only runs in tray...
>8. there won't come an icon that you have new mail...

I clicked on turbo icon. Browser started. I clicked on mail
icon to start messenger, and I had to RELOGIN to messenger.
That would explain why the new mail notification icon
didn't pop up in system tray. The connection to your mail 
was terminated even though you have the turbo icon in the
system tray.

Not sure if this is mail bug..
QA Contact: gbush → gchan
(Reporter)

Comment 6

16 years ago
hmm, I meanwhile even think this doesn't have anything to do with the turbo
icon... mozilla just only checks for mail if a messenger window is open, am I
right?!

Comment 7

16 years ago
Not quite. I tried your scenario but I only closed messenger
after sending my mail. Turbo/browser window was still open.
After waiting a minute, I got the notification icon in
system tray.

So as long you have current process running browser/messenger
the icon should pop up. But if you close both browser/messenger
and have turbo running/not running then you won't get new mail.

So it's not messenger. I'm not sure on the behavior of turbo.
I'll have to ask..

Comment 8

16 years ago
Bill, so if you close both browser/messenger, should that
log you out of mail even though turbo is running?

(Reporter)

Comment 9

16 years ago
This problem is not related to Turbo Mode only!! I am using Linux now and I
still have the same problem. Mozilla _only_ checks for new mail if a _messenger_
window is opened. Not even if a browser window is opened.

Comment 10

16 years ago
I believe this is as designed: from the spec located at:
http://www.mozilla.org/xpapps/QuickLaunch/


When the user is in quicklaunch and he closes the last window, we don't actually 
want to quit Mozilla; we want to remain open so that
subsequent launchings will be fast. For privacy and security reasons, however, 
we need to simulate a quit as closely as possible to ensure that
sensitive info like session history is cleared.  

Comment 11

16 years ago
Thanks Grace. I'll wait for Bill to confirm but I agree
from reading the link you provided this is by design.

If so, I'll mark this bug as invalid.

thanks again.
(Reporter)

Comment 12

16 years ago
This bug is no longer about the Turbo mode... I wrote that 3 times now! But
mozilla never checks for mail except the messenger is started. It doesn't check
for mail if only a browser window is open or if chatzilla is running... It ONLY
checks for mail if a messenger window is open and that is what this bug is about!

Comment 13

16 years ago
Having MoZilla checking mail in the background is a very popular feature.
For example Heise Online, Germany's most popular Newssite and Computer Magazine
Publisher,
wrote at the release of 0.9.9 that "finally a tray icon again notifies you of
new mail like with netscape 4.7".

In addition, i do personally know MANY people who would switch froum Outlook
Express to Mozilla only because of such a feature.

Getting this to work should be a top priority.

The current version of the tray icon functionally is basically a joke.
If the mail client is open anyway there isn't much need checking for mail with a
tray icon, is there ? However when only browsing websites a tray icon would be a
significant advantage - because it could make you start the messenger when
you're not really thinking that you could have mail.

Having this feature also work in Turbo Mode would further improve the
functionality and eliminate the need for third party
mail-checking-and-tray-notification-programs (and there are quite a lot of them).
But this is not what this bug is about.

I urge all of you to take this feature request seriously and implement it in the
best way possible.

Comment 14

16 years ago
Harald and Gerald,

I am trying to understand your problem. I assume you both
want a mail notification system tray icon to come up, even if
you have not logged into messenger. Correct?

Currently the way its implemented as log as you login to messenger
and have a browser from current session running, you can close
messenger and mail notification will still come up. If you don't
physically login to Messenger, then there's no way, currently,
for mail notification icon to come up. And that is what you
both are requesting?

There is a bug out there. Bug 11056 (implementing a new mail check
standalone app). I feel this bug will be a dupe of that bug.
I will mark this bug as dupe of that one. I will add both of you
to the cc list and I think you should put your comments in that
bug please.

thanks.




*** This bug has been marked as a duplicate of 11056 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 15

16 years ago
Not sure if anybody is still looking for input from me...

But, I think the assessment of the situation is correct.  Once you log into
Mail, then you remain logged in until you close all windows (mail or not).  If
you don't log into mail, then the mail alert systray icon doesn't kick in (I'm
basing that on my understanding of how it works).

Theoretically, we *could* check for mail whenever the user starts up a given
profile (e.g., by opening a browser window).  But that's not how the mail
feature was designed/implemented, apparently.
(Reporter)

Comment 16

16 years ago
hmm, thats part of what I am requesting, thanx 

Comment 17

16 years ago
thanks Bill for input..
Also, see bug 71105.  Verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.