Closed Bug 131568 Opened 21 years ago Closed 21 years ago

template/default/global/header not valid HTML 4.01

Categories

(Bugzilla :: User Interface, defect, P1)

Other
Linux
defect

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: ville.skytta, Assigned: myk)

References

Details

Attachments

(1 file)

A trivial patch follows.
Attached patch Patch v.1Splinter Review
Blocks: 47251
This is a dupe of bug 107120, however, that's already marked fixed.  Someone
broke it again I take it?
Priority: -- → P1
Target Milestone: --- → Bugzilla 2.16
Comment on attachment 74618 [details] [diff] [review]
Patch v.1

r= justdave x2
Attachment #74618 - Flags: review+
Checking in template/default/global/header;
/cvsroot/mozilla/webtools/bugzilla/template/default/global/header,v  <--  header
new revision: 1.7; previous revision: 1.6
done
er, meant to mark that fixed.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Ah, I see this was already marked fixed while I was writing this,
but here it goes anyway.  BTW; should this be in CVS already? Does not
show here...

---

Well, the link element with an ending /> has been there for some time.
Documents with tags like these don't validate as HTML 4.01, try

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
 <head>
  <link rev="made" href="mailto:foo@bar.org" />
  <title></title>
 </head>
 <body>
 </body>
</html>

...with validator.w3.org.  In fact, all HTML elements that are marked with
Forbidden end tag and Empty content model in
http://www.w3.org/TR/html4/index/elements.html must not have an end tag of
any kind.  I think it is a limitation of the W3C validator that it does
not complain about all of these, but only elements inside <head>.
And, /> is an end tag...

This is the primary reason that one can't have valid XHTML and HTML at
the same time (provided, of course, that one of these elements is used).
Further, since one of the main concerns in HTML 4 vs XHTML 1 was
browser compatibility, I see no reason why bugzilla should use />'s...

yeah, if you're using cvs-mirror it can be anywhere from 10 minutes to an hour
after the checkin before it shows up on cvs-mirror.
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.