window.close() closes window instead of tab

VERIFIED DUPLICATE of bug 103452

Status

VERIFIED DUPLICATE of bug 103452
17 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: jag-mozilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
window.close() does ask for confirmation, but then OK is clicked, all tabs are
closed, which is not what page authors meant. Javascript has no knowledge of
tabs, so a window object can only be a tab (also because scripts should't be
able to alter other tabs :)). IMHO, window.close() should do the same as ^W:
close the window only if it has a single tab, close the tab of the caller otherwise.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 103452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
vrfy dupe
this is now relnoted
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.