View Page Source doesn't show correct source after POST

VERIFIED DUPLICATE of bug 55583

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 55583
16 years ago
10 years ago

People

(Reporter: Adam Monsen, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
After POSTing to a URL, I cannot use View Page Source to get at the HTML that
was generated as a result of my POST request. Mozilla (milestone release 0.9.9,
at least) appears to simply request the page again and show me *that* source.

steps to reproduce:
1. go <a
href="http://slashdot.org/comments.pl?sid=29597&cid=0&pid=0&startat=&threshold=1&mode=thread&commentsort=0&op=Reply">here</a>
(if that link doesn't work, just try replying to a slashdot.org post)
2. enter the text 'SHOULD SHOW UP IN SOURCE' in the multiline textarea input
field titled 'Comment:'.
3. click 'Preview' button.
4. click View -> Page Source (CTRL+U)
5. words 'SHOULD SHOW UP IN SOURCE' do not appear in source.

Both Netscape Navigator 4.78 and MSIE 6.0 display the source of the current page
as I would expect (these same steps end with the words 'SHOULD SHOW UP IN
SOURCE' appearing in the source). If it is reasonable, I would recommend that
the current page source is shown instead of a freshly requested page.
(Reporter)

Comment 1

16 years ago
Sorry, I should probably add:

User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311
Build ID: 2002031115
see QA/Frequently reported Bugs (http://bugzilla.mozilla.org/duplicates.cgi)

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
> see QA/Frequently reported Bugs ...

thank you, I looked over this page. I'll do more research before reporting bugs
in the future. Still, it makes me feel better that I'm not the only one who
wishes some action on this component.

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.