Open Bug 131589 Opened 19 years ago Updated 2 years ago

Corrupt panacea.dat causing us to lose messages in offline store, and redownload message headers/rebuild .msf files of suffixed file name like folder-1.msf

Categories

(MailNews Core :: Backend, defect)

x86
All
defect
Not set
critical

Tracking

(Not tracked)

People

(Reporter: allan, Unassigned)

References

(Depends on 2 open bugs, Blocks 3 open bugs)

Details

(Keywords: dataloss, steps-wanted)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Win98, laptop, IMAP server.  I frequently use this laptop for travel so do a
most of my work in "offline" mode.  If I start Mozilla Mail offline (e.g. with
network physically disconnected),  and click any mail folder, the subject/sender
list for the messages in that folder like normal, and each icon next to the
subject indicates the message has been downloaded.  But if I click on a message,
nothing comes up in the 'view' pane.

Likewise if I double-click on the message a separate window comes up with the
subject: line at the top but the text area is empty.

If I then connect the network and File->Offline->Work Online, and click a
message, I am prompted to enter the password for my IMAP server account.  I can
then read messages normally.  If I _then_ go back offline, I can read messages
normally also.

Reproducible: Always
Steps to Reproduce:
0.  Setup: Automatically download messages for offline use
0.  Setup: IMAP account w/ Password
1.  Physically disconnect from network connection
2.  Start mozilla mail "offline"; either by:
         a) Run Profile Manager, click "Start offline", or
         b) Run Mozilla Mail, select File->Offline->Work Offline
         c) Run Navigator & select File->Work Offline, then Tasks->Mail
3.  Click any folder in the folders pane
4.  Click any message subject
    --> nothing happens.

Actual Results:  The "message text" pane never changes to display the text of
the message that's been clicked on.

Expected Results:  Should have shown the message

Netscape 6.2 for Win98 doesn't seem to have the problem.
works fine for me - you never get the message that says the message has not been
downloaded for offline use? If not, that tells me that we're not offline. Do the
meteors spin in the upper right hand corner of the window?
Hi,
I only get that notification if the messages haven't been downloaded yet.  I
always download them prior to going offline, so it only comes up for the large
ones, as expected.

As far as its behavior, sort of anecdotally, this problem seems to have
something to do with the IMAP password stuff.  "Nothing" works until the IMAP
authentication occurs, and then "everything" works afterwards.  But since I'm
starting Mail offline (and have no physical connection to the server), I never
get to the point where I enter that password (and this is the key.  If I start
mail "online", enter the password, then go "offline", it's fine.  But this
normally is not an option since it's a laptop that travels around, and doesn't
necessarily have net access).  "Nothing" and "Everything" refer to the ability
to view the message texts.

The app is definitely in offline mode when the problem occurs; the "plug" icon
in the lower-right hand of the window shows we're offline, the big M in the
upper-right stays M, doesn't spin, and the spinning //////// marks in the bottom
part of the window that show (I guess) network activity do not appear. 
ah, ok, you have remember password turned off. I'll try that.
I turned off remember password, shut down, restarted offline, and I was able to
read messages while offline. So this is still working for me. Gary, can you try
this? Allan, I'm not sure what else to try. You could try turning on "remember
password" and see if that makes a difference, purely for diagnostic purposes.
Using commercial build: 2002-03-18-05-trunk/ on NT 4.0,
I am sorry, I can't reproduce this either.

I tried both migrated/new profiles and couldn't reproduce.
Tried starting in offline mode, going offline after logging
in, physically disconnected from network, etc..and couldn't
reproduce this.

Everytime I clicked on a downloaded or non-downloaded mesg,
the Mesg pane either displayed the body of the mesg or 
the 'the body of the mesg is not downloaded..' part.

Reporter thanks for detailed steps to reproduce. Do you
see this problem, if you double click on a downloaded mesg
and it opens in a seperate window?
Have you tried a new profile with the same mail act?

I didn't have 'remember password' set.
marking as works for me.

Reporter if you can generate any new steps
to reproduce or try a current build you could reopen.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Hello - More information that may help to track down this bug.

The symptoms went away after I erased and re-created my profile.  It stayed
healthy for about a month and then mysteriously after a mozilla crash the
symptoms came back.  I had an opportunity to look into it further and found
something which may lead us closer to the cause.

After the problem re-appeared [same symptoms as originally reported, and same
method to reproduce] I noticed that there were a _few_ messages in selected
folders that came up OK.  But the rest in those folders, and all in other
folders, exhibited the original symptoms.

I tracked this down and found a correlation.  More background information first.
 My set-up is to store most or all of my folders on the IMAP server, rather than
keeping messages stored locally.  Then I use the "Offline->Download/sync" stuff
to keep a temporary local copy and work offline from the server.

On my client system (laptop PC) the path to the local files is:

  C:\WINDOWS\Application Data\Mozilla\Profiles\[profile_name]\
      [random_code]\ImapMail\[server_name]\Folders

I noticed that after the crash occured, and the problem came back, that almost
all of my folders were "duplicated" with a -1 appended to the filenames, ie for
any given name (e.g. "Folder"):

   Folder              last mod matches time of the crash
   Folder-1            last mod is current, e.g. today
   Folder-1.msf        last mod is current, e.g. today

All of the folders that had the "-1" appended were the ones that exhibited the
problem.  I renamed a particular folder back (took off the "-1") and the problem
went away for that folder.

I made a backup, clobbered & recreated the entire profile, and the problem
hasn't come back yet, but I suspect it will once a crash (or something) occurs
that makes those -1 folders.

I'll reopen the bug now that there's additional info.  Thanks,

Allan
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
thanks for the good detective work - that makes sense - what probably happened
is that your panacea.dat got corrupted (running two instances of mozilla will
cause this; I don't know of any other way of causing it). Once this happens, the
folder discovery code gets confused and starts generating these -1 .msf files,
and we have to redownload msg hdrs into the new .msf file, and the new .msf
files don't think we have the messages downloaded for offline use. It may also
be possible that some code uses the -1 .msf file and other code uses the correct
.msf file...
Status: UNCONFIRMED → NEW
Ever confirmed: true
changing summary
Status: NEW → ASSIGNED
Summary: Messages can not be viewed after starting Mail offline → Corrupt panacea.dat causing us to lose messages in offline store
Product: Browser → Seamonkey
Status: ASSIGNED → NEW
QA Contact: grylchan → offline
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Assignee: bienvenu → nobody
Keywords: dataloss
QA Contact: offline → mailnews-backend
Tony, can you reproduce this using yoru windows platform?
Severity: normal → critical
Ever confirmed: false
Component: MailNews: Backend → Backend
Product: SeaMonkey → MailNews Core
QA Contact: mailnews-backend → backend
bienvenu, is there anything feasible to do about comment 8?  (It doesn't sound like)
Summary: Corrupt panacea.dat causing us to lose messages in offline store → Corrupt panacea.dat causing us to lose messages in offline store, and redownload message headers/rebuild .msf files
(In reply to Wayne Mery (:wsmwk) from comment #12)
> bienvenu, is there anything feasible to do about comment 8?  (It doesn't
> sound like)

it might be possible to reproduce the issue by deleting panacea.dat and restarting, so some concentrated effort on debugging might help.
k. let's get this off unconfirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Re-discovery failure may be similar to unsubscribe/re-subscribe for Tb.
Setting dependency to bug 520437 for ease of tracking.
Depends on: 520437
Summary: Corrupt panacea.dat causing us to lose messages in offline store, and redownload message headers/rebuild .msf files → Corrupt panacea.dat causing us to lose messages in offline store, and redownload message headers/rebuild .msf files of suffixed file name like folder-1.msf
Blocks: 881966
Blocks: 495911
Depends on: 418551
Keywords: qawantedsteps-wanted
OS: Windows 98 → All
You need to log in before you can comment on or make changes to this bug.