bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Widevine crashes on Firefox 49.0.2 and Ubuntu 16.10




Audio/Video: GMP
a year ago
a year ago


(Reporter: Claudius Ellsel, Unassigned)


49 Branch

Firefox Tracking Flags

(Not tracked)




a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161025164528

Steps to reproduce:

After upgrading to Ubuntu 16.10 the Widevine plugin of Firefox crashes when trying to watch a video that uses this technology. Widevine works fine in Chrome.

Before upgrading it worked without problems with the same Firefox version. So I assume there is some conflict with Ubuntu.

This happens on all my three devices.

I logged into guest mode and tried it there, but same problem occurs.

One of some crash reports I sent with Firefox: https://crash-stats.mozilla.com/report/index/088a0c5c-5509-423b-8347-6ed842161022#tab-details

My corresponding question on askubuntu: http://askubuntu.com/questions/840511/firefox-widevine-plugin-crashes-immediately-after-upgrade-to-ubuntu-16-10

Actual results:

I get a crash message as soon as I start the video.

Expected results:

The video plays.

Comment 1

a year ago
Already reported this on Launchpad: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1638719
Component: Untriaged → Audio/Video: GMP
Product: Firefox → Core
Jed: Could this be a sandboxing issue again? How can we diagnose it.
Flags: needinfo?(jld)
(In reply to Chris Pearce (:cpearce) from comment #3)
> Jed: Could this be a sandboxing issue again? How can we diagnose it.

The “crash address” for these is the syscall number (via bug 1017393); there are a few places to look up the Linux/amd64 syscall numbers, one of them in m-c[1], and that tells us it's madvise.

For the syscall arguments, look in the Raw Dump tab in crash-stats; the syscall man page[2] has a table mapping argument order to registers.  So this is: madvise(0x00007fc097a92000, 0x000000000006e000, 8).  And a little chasing through headers[3] shows that 8 in that context is MADV_FREE.

So this is another duplicate of bug 1303813.  Recall that that needs Firefox to be built on a new enough host that the headers define MADV_FREE for this bug to happen, so Mozilla's own builds are unaffected and we didn't notice until after 49 was released and downstream builds started running into it.  Also note that 50 has the fix, so this will be “fixed” in a week when 50 moves from beta to release even if nobody does anything else about it.

[1] http://searchfox.org/mozilla-central/source/security/sandbox/chromium/sandbox/linux/system_headers/x86_64_linux_syscalls.h
[2] http://man7.org/linux/man-pages/man2/syscall.2.html
[3] https://github.com/torvalds/linux/blob/master/include/uapi/asm-generic/mman-common.h
Last Resolved: a year ago
Flags: needinfo?(jld)
Resolution: --- → DUPLICATE
Duplicate of bug: 1303813

Comment 5

a year ago
Thanks! Will wait for Firefox 50 then.

Comment 6

a year ago
Can confirm that this does not occur in Firefox 50.
You need to log in before you can comment on or make changes to this bug.