sincos() should be used on more platforms

RESOLVED FIXED in Firefox 52

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: petr.sumbera, Assigned: petr.sumbera)

Tracking

45 Branch
mozilla52
Points:
---

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; SunOS i86pc; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20161020232743

Steps to reproduce:

sincos() is called from js/src/jsmath.cpp only on systems with __GLIBC__ defined.

However Solaris has also sincos() support:
http://docs.oracle.com/cd/E36784_01/html/E36877/sincos-3m.html

And since configure check finds __sincos() in libm on Solaris it tries to use it. But it fails because it doesn't have defined prototype.

Therefore configure check for sincos() should be added.
Attachment #8808601 - Flags: review?(dtownsend)
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Attachment #8808601 - Flags: review?(dtownsend) → review?(jdemooij)
Comment on attachment 8808601 [details] [diff] [review]
Bug1315956.patch

Review of attachment 8808601 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8808601 - Flags: review?(jdemooij) → review+
Assignee: nobody → petr.sumbera
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ce4e1e1d0bff
Use sincos() on more platforms. r=jandem
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ce4e1e1d0bff
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.