If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wrong z-ordering with CSS transform

RESOLVED DUPLICATE of bug 689498

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 689498
11 months ago
11 months ago

People

(Reporter: vincent, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.87 Safari/537.36

Steps to reproduce:

1. Open http://jsbin.com/necuxiy/edit?html,css,output
Two elements are layered on top of each other, and receiving a simple rotateY transformation. First one -60deg, second one 60deg. We should only see left part of first element and right part of second element.


2. Hover over elements


Actual results:

1. Elements are not correctly z-ordered.
We should not see left part of second element, because it should be below first element.

2. Transition performs really badly


Expected results:

1. A great z-ordering
Works well in Chrome, Opera, Safari, Edge

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689498
You need to log in before you can comment on or make changes to this bug.