If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Page loaded" event from the main browser window forces "lose focus" of an opened preferences window

RESOLVED DUPLICATE of bug 105225

Status

SeaMonkey
UI Design
RESOLVED DUPLICATE of bug 105225
16 years ago
4 years ago

People

(Reporter: Cip, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

If you're using the preferences window and the browser has completed loading a
page form a slow responding URL the preferences window looses focus in favor of
the newly loaded window.

Reproducible: Always
Steps to Reproduce:
1.Open a preferences window
2.Leave the preferences window open and type in the URL box a known slow
reponding URL. While Mozilla attepts to load the URL switch back to preferences
window and start browsing the preferences tree.
3.Wait until Mozilla finishes loading the page in the background.

Actual Results:  When Mozilla finished loading the page it forces focus to the
browsing window.

Expected Results:  Mozilla should have left focus on the current preferences
window where I was working.

It happens only at "finished loading page" event. If during the slow load there
is a warning like permission to set a cookie you lose focus from the preferences
window, answer the question and the focus automagically returns to the
preferences window you've been working on.
Duplicate of one of the "Browser takes focus on finishing pageload" bugs.
Reporter, please retest with a current build -- at least one bug like this has
been fixed since 0.9.8.
Whiteboard: DUPEME

Comment 2

16 years ago
Looks very similar to bug 105225 which is a special case of bug 88810.

Comment 3

16 years ago
reporter hasn't responded for a couple of months. resolving as a dupe per comment 2


*** This bug has been marked as a duplicate of 105225 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.