Closed Bug 1317066 Opened 3 years ago Closed 2 months ago

Crash in MaildirStoreParser::TimerCallback

Categories

(MailNews Core :: Backend, defect, critical)

Unspecified
All
defect
Not set
critical

Tracking

(thunderbird50 affected, thunderbird_esr45 affected)

RESOLVED DUPLICATE of bug 1506613
Tracking Status
thunderbird50 --- affected
thunderbird_esr45 --- affected

People

(Reporter: wsmwk, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [blocked on bug 906469])

Crash Data

I question whether this is really maildir.

Almost all windows crashes are Chris' [1] - for example bp-82f15028-a1da-4319-87fd-de3102161111
Chris can you describe what are you doing when you crash?

bp-5a13db8d-1119-4320-aec8-5b19a2161111 is a linux example. The stack is similar to the Windows crashes
0 	libxul.so	MaildirStoreParser::TimerCallback	/build/thunderbird-y9E9Hq/thunderbird-45.4.0+build1/mailnews/local/src/nsMsgMaildirStore.cpp:1238
1 	libxul.so	nsTimerImpl::Fire	/build/thunderbird-y9E9Hq/thunderbird-45.4.0+build1/mozilla/xpcom/threads/nsTimerImpl.cpp:526
2 	libxul.so	nsTimerEvent::Run	/build/thunderbird-y9E9Hq/thunderbird-45.4.0+build1/mozilla/xpcom/threads/TimerThread.cpp:282
3 	libxul.so	nsThread::ProcessNextEvent	/build/thunderbird-y9E9Hq/thunderbird-45.4.0+build1/mozilla/xpcom/threads/nsThread.cpp:972
4 	libxul.so	NS_ProcessNextEvent	/build/thunderbird-y9E9Hq/thunderbird-45.4.0+build/mozilla/xpcom/glue/nsThreadUtils.cpp:297 


[1]  66f96c42-7973-4143-87cd-ec78e2161111
1d30a878-55ff-4381-8e20-0318c2161111
b5e38479-f5b2-40b1-abcc-5cc132161111
e26ab6f1-4550-460e-bc63-fefc32161111
f3089b6b-fe31-4ac9-a5e9-b3c1a2161111
60258ee2-eb65-48f4-8661-b27072161111
3065dfe3-b079-4a4f-b587-c353f2161111
71a48e9a-912c-4235-a7e5-31b0e2161110
2065acbb-d519-46a8-8c07-1d3f32161110
e993268c-9523-4881-ab29-3cf902161110
92324393-6172-4c44-bcce-420352161110
53ae3c01-ffce-4a79-9016-109322161109
cf81fab4-ca01-4f6f-8363-9c2c52161109
a1b36a84-98be-41d7-8975-462012161109
e40a7659-4638-46e0-b013-5a03c2161109
7ec8dcec-0e70-4b87-b5a5-fc7ce2161109
Flags: needinfo?(chris.ramsden)
chris comments in just one crash "viewing a large saved search folder" bp-b5e38479-f5b2-40b1-abcc-5cc132161111
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #1)
> chris comments in just one crash "viewing a large saved search folder"
> bp-b5e38479-f5b2-40b1-abcc-5cc132161111

I am (was) running TB50.0b4 on Windows 7 Pro (at my workplace) and yes I am using maildir. I am running a very similar set-up (i.e. TB50, maildir, with mostly all the same add-ons) in LMDE here at home and don't see these crashes. 

I switched back to 45.4.0 on Friday and still saw the crashes. I can't say that there is anything in particular that I am doing when it happens. However I had been adjusting the folders included in a saved search (it looks for Junk labels in /all/ my folders and I'd added a few that had been overlooked) and this felt like something that had changed recently. 

Maybe OT but both Firefox (often) and TB (occasionally) frequently "freeze" on the Windows machine and have to be killed via Task Manager. I don't see this behaviour with the same versions in LMDE. I can't tell if it's TB/Firefox/gecko etc or specific to that particular PC. 

ISTR that running TB or Fx in Safe Mode didn't make any difference. I switched to Pale Moon and have not seen any browser freezes since.
Flags: needinfo?(chris.ramsden)
Depends on: 906469
Slightly more common in TB52.x
Whiteboard: [blocked on bug 906469]
(In reply to Chris Ramsden from comment #2)
> ...
> Maybe OT but both Firefox (often) and TB (occasionally) frequently "freeze"
> on the Windows machine and have to be killed via Task Manager. I don't see
> this behaviour with the same versions in LMDE. I can't tell if it's
> TB/Firefox/gecko etc or specific to that particular PC. 

Still seeing Thunderbird freezes in newer versions?
How big are the "big folders"?
Flags: needinfo?(chris.ramsden)
Flags: needinfo?(chris.ramsden)
Blocks: 1506613

Hi, fixed a crash in MaildirStoreParser::TimerCallback in bug 1506613. Also bug 906469 seems to be fixed.
You may ask for bug 1506613 be backported to TB68 and then recheck if the crashes here still happen.

No longer blocks: 1506613
Depends on: 1506613
Flags: needinfo?(vseerror)

Chris, your crashes are gone?

Patch went out in beta and 60.7.1

Status: NEW → RESOLVED
Closed: 2 months ago
Flags: needinfo?(vseerror)
Resolution: --- → DUPLICATE
Duplicate of bug: 1506613
You need to log in before you can comment on or make changes to this bug.