intl/lwbrk/nsJISx4051LineBreaker.cpp fails with older ICU lib

RESOLVED DUPLICATE of bug 1316540

Status

()

Core
String
RESOLVED DUPLICATE of bug 1316540
2 years ago
2 years ago

People

(Reporter: Martin Husemann, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(firefox52 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8810118 [details] [diff] [review]
conditionalize newer line breaks on the ICU version in use

ICU version 58 introduced a few more line breaking characters, and we compile time assert that the number (U_LB_COUNT) is the same as the static array sUnicodeLineBreakToClass.

Comment 1

2 years ago
Asserting system U_LB_COUNT is equal bundled one is bogus. It may gain more line breaks classes in future ICU versions. Anyway, the discussion what to do --with-system-icu happens in bug 1316540.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1316540
You need to log in before you can comment on or make changes to this bug.