[EME] "waitingforkey" might fire earlier than MDSM starts buffering

RESOLVED DUPLICATE of bug 1317201

Status

()

Core
Audio/Video: Playback
P3
normal
RESOLVED DUPLICATE of bug 1317201
a year ago
a year ago

People

(Reporter: jwwang, Assigned: jwwang)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

a year ago
http://searchfox.org/mozilla-central/rev/4b6cab91f93c73ae591dafaea40fd5704b41810e/dom/html/HTMLMediaElement.cpp#4757

For |nextFrameStatus==NEXT_FRAME_UNAVAILABLE && mWaitingForKey == WAITING_FOR_KEY|, "waitingforkey" will be fired even before MDSM starts buffering. This could happen when decoding is slow and nextFrameStatus reported by MDSM fluctuates between NEXT_FRAME_UNAVAILABLE and NEXT_FRAME_AVAILABLE.
(Assignee)

Updated

a year ago
Assignee: nobody → jwwang
Blocks: 1015800
Depends on: 1310548
Priority: -- → P3
(Assignee)

Comment 1

a year ago
Bug 1317201 should fix this problem.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1317201
You need to log in before you can comment on or make changes to this bug.