Add remote type match check to nsFrameLoader::SwapWithOtherRemoteLoader

RESOLVED FIXED in Firefox 54

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bobowen, Assigned: bobowen)

Tracking

Trunk
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 fixed)

Details

(Whiteboard: sbwc2, sblc3, sbmc2,[e10s-multi:M2])

Attachments

(1 attachment)

This check was suggested for bug 1147911 comment 34, but it broke dragging tabs in and out of the browser.

The check should be valid, so this bug is to follow-up and fix whatever is causing the problem.
Then we can also add the check in nsFrameLoader::SwapWithOtherRemoteLoader to make sure the remote types match.
Looks like another change has fixed this, but I'm not sure what (which is annoying).

But I think it means I can land this check now, which is good.
I tried to go back and reproduce this on the original last changeset for bug 1147911 and couldn't.
So it's quite probable that I made a mistake when I initially tried to add this check. :-(

Anyway, here's a try push:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2028bd545ae85c1793601c856cd9ff74497d6dda
We have some devtools failures, I think just when swapping, because bug 1318767 changed the parameters for updateBrowserRemoteness, but missed the call in swap.js [1].

Here's another try push, with that fixed:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=da7025827cdd2a75d49fc7e238dccd8742f59d46

[1] https://hg.mozilla.org/mozilla-central/file/3cedab21a7e6/devtools/client/responsive.html/browser/swap.js#l153
Blocks: 1318767
... and a fix for that has just landed in bug 1331601.
Depends on: 1331601
No longer blocks: 1318767
Attachment #8829367 - Flags: review?(wmccloskey) → review+
Pushed by bobowencode@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/34c57b2a36e3
Only allow nsFrameLoader::SwapWithOtherRemoteLoader when remote types match. r=billm
https://hg.mozilla.org/mozilla-central/rev/34c57b2a36e3
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.