Closed Bug 1317469 Opened 3 years ago Closed 3 years ago

SHA512SUMS of Firefox for Android does not contain apk's

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set

Tracking

(firefox53 fixed)

VERIFIED FIXED
Tracking Status
firefox53 --- fixed

People

(Reporter: iceberg, Assigned: nthomas)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20160924153504

Steps to reproduce:

Open the page https://ftp.mozilla.org/pub/mobile/releases/49.0.2/


Actual results:

The file SHA512SUMS does not report the values of the apk downloadable files in the folders android-api-15 and android-x86


Expected results:

The file SHA512SUMS must report the values of all the apk files.
Ben would you check that I've moved this to an appropriate component.
Component: General → Releases
Flags: needinfo?(bhearsum)
Product: Firefox for Android → Release Engineering
QA Contact: rail
Version: 49 Branch → unspecified
The most recent release (https://ftp.mozilla.org/pub/mobile/releases/50.0/SHA512SUMS) contains only the source tarball and bundle.
Assignee: nobody → nthomas
Component: Releases → Release Automation
Flags: needinfo?(bhearsum)
Summary: Is missing in ftp.mozilla.org the sha512sums of Firefox for Android (apk files) → SHA512SUMS of Firefox for Android does not contain apk's
jlund, this should do the trick to pick up the fennec apk, while ignoring bouncer.apk & robocop.apk.

mconnor, this will also stop pushing bouncer.apk to locations like https://archive.mozilla.org/pub/mobile/releases/50.0/android-api-15/multi/bouncer.apk. Does that fit OK with our workflow for pre-installs ?
Attachment #8811105 - Flags: review?(jlund)
Attachment #8811105 - Flags: feedback?(mconnor)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8811105 [details] [diff] [review]
[gecko] Include fennec.*\.apk

Review of attachment 8811105 [details] [diff] [review]:
-----------------------------------------------------------------

huh, looks like we haven't been providing a checksum for at least the last few releases. I suppose this hasn't been caught since this is a copy of the apk we ship via play store.
Attachment #8811105 - Flags: review?(jlund) → review+
Attachment #8811105 - Flags: feedback?(mconnor) → feedback?(mkaply)
Bouncer isn't really being used right now, so I don't think that's an issue.
Attachment #8811105 - Flags: feedback?(mkaply) → feedback+
Pushed by nthomas@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f3f76d129bfe
SHA512SUMS of Firefox for Android doesn't contain APKs, r=jlund DONTBUILD
(In reply to Nick Thomas [:nthomas] from comment #7)
> Should be fixed in 51.0b2, and 51.0.1 or 51.1.0 (whichever comes next).

I mean 51.0b2, and 50.0.1 or 50.1.0 (whichever comes next).
https://hg.mozilla.org/mozilla-central/rev/f3f76d129bfe
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Worked for 51.0b2 - https://archive.mozilla.org/pub/mobile/releases/51.0b2/SHA512SUMS
Missed 50.0.1 because the branch for that was cut earlier than ee755a8e7cce, but it'll be fixed for 50.1.0.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.