Closed Bug 131758 Opened 23 years ago Closed 15 years ago

Tooltips overlap the Dock when moused over

Categories

(Core :: XUL, defect)

PowerPC
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 300904

People

(Reporter: moz-bugzilla, Unassigned)

References

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2002031005

If the Dock is locked to the bottom of the desktop and you have a relatively
tall browser window open (e.g., maximized), mousing over the window's widgets at
the bottom (composer, mail, SSL lock, etc.) with Tooltips enabled and the Dock
displayed will show the Tooltips overlayed on top of the Dock.

Reproducible: Always
Steps to Reproduce:
1. Enable Tooltips in the Preferences.
2. Open and resize a browser window so that its bottom edge would overlap with
the region reserved for the Dock.
3. Make sure the Dock is being displayed (either by turning off auto-hide or
bringing up the Dock).
4. With the Dock still being displayed, mouse over one of the icons at the
bottom of the browser window (e.g., the SSL lock).

Actual Results:  The Tooltip is displayed on top of the Dock.

Expected Results:  Tooltips should never be displayed on the Dock, even if the
mouse pointer is currently positioned over a Mozilla widget through the Dock.
Looks to me like tooltips show above the area reserved for the Dock, not over it
- except that if the Moz window is actually positioned *behind* the Dock, and
you mouseover the Dock, Moz thinks you're mousing over Moz buttons, and shows
tooltips, which it shouldn't do.

Also, if your Dock has magnification on, then the Dock will take up more
vertical space than is normally reserved for it; tooltips may be displayed on
top of the Dock in this case.  Making tooltips not appear if the mouse is within
the area currently being occupied by the Dock (not just the space normally
reserved for the Dock, since the Dock can change size quite a bit) would fix this.

Note that tooltips should still work if the item being moused over is at the
bottom of the screen in the vertical space reserved for the Dock, but not
actually being covered up by the Dock (for example, if you move a window down so
the status bar is behind the Dock, but the buttons on the left of the status bar
are beside the Dock, not behind it).

That was probably somewhat incoherent; sorry.
Confirmed using FizzillaCFM/2002041712 (RC1).

Tried the same thing in IE: enabled Tooltips and moused over the Home button,
resulting in a Tooltip. Moved the IE window down so the Home button was
underneath the Dock, and no Tooltip was shown.

Perhaps there's a Tooltip Service in OS X that can be used to automatically
determine whether or not it's appropriate to actually show it?
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
What is worse:

 Mozilla puts tooltips on a higher stacking order than everything else in the
os. When Mozilla loses focus, a tooltip will persist above the current application.

This is annoying and distracting because the tooltip that was generated by
mozilla has nothing to do with the current application. When you the dock on a
side (left or right), you will notice the problem much more.

Here's how I reproduce the situation:

1) use a left dock with dock hiding on.
2) put a text editor application icon in the upper part of the dock.
3) launch your text editor.
3) go to dhtmlkitchen.com (note: this bug is not url-specific)
4) position the window so that the cuttingboard is aligned with your text-editor
icon in the dock. (from step 2)
5) move the mouse quickly across the cuttingboard to the text-editor icon. When
the dock pops out, click the text-editor icon.

Result:
7/10 times, the tooltip will appear above the text editor (BBEdit). Clicking the
tooltip will draw focus to mozilla and the tooltip will eventually die. 


"...Looks to me like tooltips show above the area reserved for the Dock, not
over it..."

The words "over" and "above" can be confusing in this matter. Better to use the
terms "stacking order," "in front of," and "behind."
stefan, do you see this? I suspect both commentors are gone.
Assignee: hyatt → nobody
QA Contact: shrir → xptoolkit.xul
Yeah, I see this on a recent seamonkey trunk build. I moved the browser window so parts of it was under the dock, when I then hovered over the dock I got a tooltip from seamonkey.
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
The tooltips open because Gecko thinks the mouse is still over our window. Bug 300904 has a little less noise (shorter comments), so duping there.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.