Crash in mozilla::net::CrashWithReason

RESOLVED DUPLICATE of bug 1315905

Status

()

Core
Networking: HTTP
--
critical
RESOLVED DUPLICATE of bug 1315905
11 months ago
6 days ago

People

(Reporter: ting, Unassigned)

Tracking

({crash})

52 Branch
x86
Windows 8
crash
Points:
---

Firefox Tracking Flags

(firefox51 affected, firefox52 affected, firefox53 affected)

Details

(Whiteboard: [OA][userContextId], crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is 
report bp-3804a7bc-4d7d-442b-91ca-020bf2161115.
=============================================================
#7 top crash on Windows for Nightly 52.0a1 20161113030203, 23 crashes from 19 installations. The crash reason is: 

  "GetValidatedAppInfo | App does not have permission"

Bug 1289001 marked 52 fixed, but it doesn't seem the case.
(In reply to Ting-Yu Chou [:ting] from comment #0)
> Bug 1289001 marked 52 fixed, but it doesn't seem the case.

The signature is related to several different crashes (bug 1289001 fixed two different crashes), so it's better to open a new bug for the remaining crashes rather than fixing everything in a single bug.
Crash Signature: [@ mozilla::net::CrashWithReason] → [@ mozilla::net::CrashWithReason] [@ IPCError-browser | (msgtype=0xAE0005,name=PNecko::Msg_PHttpChannelConstructor) Value error: message was deserialized, b] [@ IPCError-browser | (msgtype=0xB00005,name=PNecko::Msg_PHttpChannelConstructor) Value …
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected

Updated

11 months ago
Whiteboard: [OA][userContextId]
Created attachment 8813174 [details] [diff] [review]
necko_test.patch

I would like to see what the child process does when the channel is created.
With this patch I do:

1. sync HTTP Channel creation
2. the check happens in RecvPHttpChannelConstructor so that we can kill the child sending IPC_FAIL.
Attachment #8813174 - Flags: review?(wmccloskey)
Of course this patch should stay in m-i/m-c just for a couple of days. No more.

Comment 4

11 months ago
Comment on attachment 8813174 [details] [diff] [review]
necko_test.patch

Review of attachment 8813174 [details] [diff] [review]:
-----------------------------------------------------------------

I could be wrong, but I think that bug 1315905 eliminates this crash. UsingNeckoIPCSecurity is false on desktop, so we'll return here:
http://searchfox.org/mozilla-central/rev/59bb309e38b10aba63dea8505fb800e99fe821d6/netwerk/ipc/NeckoParent.cpp#219

Not sure if that was the intention. The patch would be fine if we were still crashing, so r+ :-). But please don't land this unless we resolve this issue, since it just adds a sync message pointlessly.

::: netwerk/ipc/NeckoParent.cpp
@@ +296,5 @@
> +  const char *error = CreateChannelLoadContext(aBrowser, Manager(),
> +                                               aSerialized, requestingPrincipal,
> +                                               loadContext);
> +  if (error) {
> +    printf_stderr("NeckoParent::AllocPHttpChannelParent: "

Did you mean to keep the printf around?
Attachment #8813174 - Flags: review?(wmccloskey) → review+
Marco, can you help me to confirm (or not) that the bug has been already resolved by bug 1315905 ?
Flags: needinfo?(mcastelluccio)
(In reply to Andrea Marchesini [:baku] from comment #5)
> Marco, can you help me to confirm (or not) that the bug has been already
> resolved by bug 1315905 ?

I see no crashes on 53.0a1 since bug 1315905 landed.
Yes, the last build ID in the crash reports is 20161117030212, the first build ID containing the fix from bug 1315905 is 20161118030222.

So it looks like bug 1315905 fixed the crash (unless the signature changed again).

https://crash-stats.mozilla.com/search/?signature=%3Dmozilla%3A%3Anet%3A%3ACrashWithReason&product=Firefox&version=53.0a1&date=%3E%3D2016-11-16T12%3A09%3A07.000Z&date=%3C2016-11-23T12%3A09%3A07.000Z&_sort=-date&_facets=signature&_facets=build_id&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-build_id
Flags: needinfo?(mcastelluccio)
Valentin, let me know if you want to reopen it.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(valentin.gosu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1315905

Comment 9

11 months ago
I filed bug 1319881 to figure out what to do here.

Updated

11 months ago
Flags: needinfo?(valentin.gosu)

Updated

11 months ago
Blocks: 1322610
You need to log in before you can comment on or make changes to this bug.