Closed Bug 1317701 Opened 4 years ago Closed 1 month ago

Delay converter-observer registration

Categories

(DevTools :: General, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1214629

People

(Reporter: gkrizsanits, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [e10s-multi:+])

To improve content process startup time I was wondering if we could delay the registration here, since it triggers to load of the devtools loader. Alternatively we could somehow simply this code to require less SDK magic...

List of things we load for this file before we would start loading any content in a new tab (if it's a fresh content process).

---Import: resource://devtools/shared/Loader.jsm
---Import: resource://gre/modules/commonjs/toolkit/loader.js
---Import: resource://gre/modules/osfile/ospath_unix.jsm
---Import: resource://devtools/shared/loader-plugin-raw.jsm
---Subscript: resource://devtools/shared/builtin-modules.js
---Import: resource://gre/modules/jsdebugger.jsm
---Subscript: resource://devtools/client/jsonview/converter-sniffer.js
---Subscript: resource://gre/modules/commonjs/sdk/platform/xpcom.js
---Subscript: resource://gre/modules/commonjs/sdk/util/object.js
---Subscript: resource://gre/modules/commonjs/sdk/util/array.js
---Subscript: resource://gre/modules/commonjs/sdk/core/heritage.js
---Subscript: resource://gre/modules/commonjs/sdk/util/uuid.js
---Subscript: resource://devtools/client/jsonview/converter-child.js
---Subscript: resource://gre/modules/commonjs/sdk/dom/events.js
---Import: resource://gre/modules/ShimWaiver.jsm
---Subscript: resource://gre/modules/commonjs/sdk/clipboard.js
---Subscript: resource://gre/modules/commonjs/sdk/url.js
---Subscript: resource://gre/modules/commonjs/sdk/base64.js
---Subscript: resource://gre/modules/commonjs/sdk/deprecated/api-utils.js
---Subscript: resource://gre/modules/commonjs/sdk/lang/type.js
Blocks: 1317304
Whiteboard: [e10s-multi:?]
I think most of these are related to bug 1302996 and especially the jsonview components, which pulls tons of SDK modules. May be I should land part of my patch that strips unnecessary SDK modules from everything but jsonview. Jsonview requires more work as we have to manually replace "xpcom" helper usage with just Components.* equivalents.

This isn't only for the content process, it also applies to the parent process and firefox startup.
Just pushed patches to bug 1302996. Hopefully this is going to significantly reduce the impact of devtools. If that's not enough, we can look into delaying. We can delay JSON specifics from devtools/client/jsonview/converter-observer.js.
We may also be more aggressive and merge the converter-child/converter-sniffer into converter-observer to prevent starting the devtools loader at all.
Blocks: 1336380
Whiteboard: [e10s-multi:?] → [e10s-multi:+]
Product: Firefox → DevTools
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1214629
You need to log in before you can comment on or make changes to this bug.