Closed Bug 1317707 Opened 5 years ago Closed 5 years ago

Intermittent test_direct_update.py TestDirectUpdate.test_update | UnknownCommandException: acceptConnections

Categories

(Testing :: Firefox UI Tests, defect)

Version 3
defect
Not set
normal

Tracking

(firefox50 unaffected, firefox51 unaffected, firefox52 fixed, firefox53 fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

Details

(Keywords: intermittent-failure, regression)

This is actually a regression from my patch on bug 1309556. Looks like we missed to implement a backward compatible check here.
Assignee: nobody → hskupin
Blocks: 1309556
Status: NEW → ASSIGNED
Keywords: regression
Ok, so the problem here is that we are now trying to restart Firefox with the restart button. This has been implemented as a follow-up on bug 1304656, which is the real regressor here. 

I would propose that we check the version of Firefox and only use the button if the pre-version is 52.0 or higher. Otherwise we do a normal in_app restart.
Blocks: 1304656
No longer blocks: 1309556
I think the best here would be to get the patch on bug 1304656 backed-out until the minimum version our update tests have to support reaches 52.0.
This is fixed now with the backout of bug 1304656.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.